summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClemens Fruhwirth <clemens@endorphin.org>2021-01-29 19:57:37 +0100
committerPetr Štetiar <ynezz@true.cz>2021-03-03 22:51:39 +0100
commit1f5e7224868109a170a9248d18f8d2b6124e9c5a (patch)
tree4b117c6e5f3c6ec1d48a1b55640fecb5da4aa2d5
parentcae69d558135456976b8fc6cb08530d1358cf6d5 (diff)
downloadopenwrt-1f5e7224868109a170a9248d18f8d2b6124e9c5a.tar.gz
openwrt-1f5e7224868109a170a9248d18f8d2b6124e9c5a.tar.bz2
openwrt-1f5e7224868109a170a9248d18f8d2b6124e9c5a.zip
Revert "build: replace which with Bash command built-in"
This reverts commit c7aec47e5e3a3ff7b5fdaa11cd1e62cae6746acb. The original commit replaces 'which' with 'command'. Sadly most of them are not equivalent and for 'which -a', there is no easy replacements that would not reimplement PATH parsing logic. Hence revert. Keeping a dependency on which is absolutely fine. Signed-off-by: Clemens Fruhwirth <clemens@endorphin.org>
-rw-r--r--Makefile2
-rw-r--r--include/cmake.mk2
-rw-r--r--include/prereq.mk4
3 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index aecee6929e..e18bc18608 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir
world:
-DISTRO_PKG_CONFIG:=$(shell command -pv pkg-config | grep -E '\/usr' | head -n 1)
+DISTRO_PKG_CONFIG:=$(shell which -a pkg-config | grep -E '\/usr' | head -n 1)
export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
ifneq ($(OPENWRT_BUILD),1)
diff --git a/include/cmake.mk b/include/cmake.mk
index de8022ca57..96c4d7df34 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -15,7 +15,7 @@ MAKE_PATH = $(firstword $(CMAKE_BINARY_SUBDIR) .)
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
cmake_tool=$(TOOLCHAIN_DIR)/bin/$(1)
else
- cmake_tool=$(shell command -v $(1))
+ cmake_tool=$(shell which $(1))
endif
ifeq ($(CONFIG_CCACHE),)
diff --git a/include/prereq.mk b/include/prereq.mk
index c11178a884..23d5ded9b2 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -49,7 +49,7 @@ endef
define RequireCommand
define Require/$(1)
- command -pv $(1)
+ which $(1)
endef
$$(eval $$(call Require,$(1),$(2)))
@@ -103,7 +103,7 @@ define SetupHostCommand
$(call QuoteHostCommand,$(11)) $(call QuoteHostCommand,$(12)); do \
if [ -n "$$$$$$$$cmd" ]; then \
bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
- command -pv "$$$$$$$${cmd%% *}")"; \
+ which "$$$$$$$${cmd%% *}")"; \
if [ -x "$$$$$$$$bin" ] && eval "$$$$$$$$cmd" >/dev/null 2>/dev/null; then \
mkdir -p "$(STAGING_DIR_HOST)/bin"; \
ln -sf "$$$$$$$$bin" "$(STAGING_DIR_HOST)/bin/$(strip $(1))"; \