summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-10-12 22:31:38 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-10-12 22:36:23 +0200
commit9caa86fba5471121c881da9ae661b221fc54a6f0 (patch)
tree96914da25bc0d9ed49a6a4b6139138a98d6df23e
parentc3ffb0e7d502784f6335bf21aaad7942253ed53d (diff)
downloadopenwrt-9caa86fba5471121c881da9ae661b221fc54a6f0.tar.gz
openwrt-9caa86fba5471121c881da9ae661b221fc54a6f0.tar.bz2
openwrt-9caa86fba5471121c881da9ae661b221fc54a6f0.zip
kernel: kmod-rtc-pcf2127: Fix dependencies
Add missing dependencies to i2c-core and regmap-spi. These get activated when these modules are build in this driver, which is the case when we build all modules. This fixes the build on some targets. This was found by the buildbot. Fixes: 34e2526f9fcc ("kernel: add kmod-rtc-pcf2127") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--package/kernel/linux/modules/other.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 3abd1f48f6..276a8f09ac 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -603,6 +603,7 @@ define KernelPackage/rtc-pcf2127
SUBMENU:=$(OTHER_MENU)
TITLE:=NXP PCF2127 and PCF2129 RTC support
DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+ DEPENDS:=+kmod-i2c-core +kmod-regmap-spi
KCONFIG:=CONFIG_RTC_DRV_PCF2127 \
CONFIG_RTC_CLASS=y
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf2127.ko