summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bauer <david.bauer@uniberg.com>2024-08-19 15:25:10 +0200
committerDavid Bauer <mail@david-bauer.net>2024-09-11 00:37:34 +0200
commitae42ecaad4e7b4878083f08a2cba6ce511ac6c43 (patch)
treef715d0bffc00137e33dc8a2c094c32838c91a324
parent8d7676dfba2524f8cf615fee68dc4075195fda7b (diff)
downloadopenwrt-ae42ecaad4e7b4878083f08a2cba6ce511ac6c43.tar.gz
openwrt-ae42ecaad4e7b4878083f08a2cba6ce511ac6c43.tar.bz2
openwrt-ae42ecaad4e7b4878083f08a2cba6ce511ac6c43.zip
ucode: fix host installation
The path for linking libucode.so was not specified for the ucode binary. This breaks execution of ucode in the host context. Signed-off-by: David Bauer <david.bauer@uniberg.com>
-rw-r--r--package/utils/ucode/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/package/utils/ucode/Makefile b/package/utils/ucode/Makefile
index aa7a28483d..125f32ba65 100644
--- a/package/utils/ucode/Makefile
+++ b/package/utils/ucode/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ucode
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=https://github.com/jow-/ucode.git
@@ -25,16 +25,17 @@ include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk
-CMAKE_OPTIONS += -DSOVERSION=$(PKG_ABI_VERSION)
+CMAKE_OPTIONS += \
+ -DSOVERSION=$(PKG_ABI_VERSION)
+ -DCMAKE_SKIP_RPATH=FALSE \
+ -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOSTPKG}/lib"
ifeq ($(HOST_OS),Darwin)
CMAKE_HOST_OPTIONS += \
- -DCMAKE_SKIP_RPATH=FALSE \
- -DCMAKE_MACOSX_RPATH=1 \
- -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOSTPKG}/lib"
+ -DCMAKE_MACOSX_RPATH=1
else
CMAKE_HOST_OPTIONS += \
- -DSOVERSION=$(PKG_ABI_VERSION)
+ -DUSE_RPATH="${STAGING_DIR_HOSTPKG}/lib"
endif
CMAKE_HOST_OPTIONS += \