summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuixi Zhou <zhouruixi@gmail.com>2019-10-05 18:16:33 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2019-10-12 23:51:08 +0200
commitb30e481b6cf09a77f50bb7f07dbe73f58699262d (patch)
treec26e2348090c1c4b31c0a4423a4e8d7cf20d6a08
parentb10a4533670e32a19b4dcc7f90a5d52c679ddf91 (diff)
downloadopenwrt-b30e481b6cf09a77f50bb7f07dbe73f58699262d.tar.gz
openwrt-b30e481b6cf09a77f50bb7f07dbe73f58699262d.tar.bz2
openwrt-b30e481b6cf09a77f50bb7f07dbe73f58699262d.zip
kernel: NFSD: add dependency kmod-crypto-arc4 for kmod-fs-nfs-common-rpcsec
crypto-arc4 move into a module with commit c3a78955f34a61d402044f357f54f21c75a19ff9, fs-nfs-common-rpcsec compile error without arc4 support. Ref: https://github.com/openwrt/packages/issues/9912 Fixes: c3a78955f34a ("kernel: move crypto-arc4 into a module") Signed-off-by: Ruixi Zhou <zhouruixi@gmail.com>
-rw-r--r--package/kernel/linux/modules/fs.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 47170058b2..3ffe82cbe8 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -389,7 +389,8 @@ define KernelPackage/fs-nfs-common-rpcsec
+kmod-crypto-md5 \
+kmod-crypto-sha1 \
+kmod-crypto-hmac \
- +kmod-crypto-ecb
+ +kmod-crypto-ecb \
+ +kmod-crypto-arc4
KCONFIG:= \
CONFIG_SUNRPC_GSS \
CONFIG_RPCSEC_GSS_KRB5