summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlberto Bursi <alberto.bursi@outlook.it>2019-07-14 03:11:00 +0200
committerPetr Štetiar <ynezz@true.cz>2019-07-17 12:16:29 +0200
commitbb27cde2579b0273c464e5ccd3dda7d14e84fd23 (patch)
treea24b634af176ae752ac68bb65d0b19ce1fe646ec
parent4c46bbbd930406449f4dbb1a07204ef9187de05c (diff)
downloadopenwrt-bb27cde2579b0273c464e5ccd3dda7d14e84fd23.tar.gz
openwrt-bb27cde2579b0273c464e5ccd3dda7d14e84fd23.tar.bz2
openwrt-bb27cde2579b0273c464e5ccd3dda7d14e84fd23.zip
x86: add modern network modules to Generic target
Many Atom-based embedded/industrial x86 boards can't run 64bit operating systems due to either processor or board firmware limitations, but they have modern interfaces (PCIe) or have modern Intel gigabit controllers onboard. With the current default package selection for x86 Generic target their network won't work. Add the modern gigabit network modules needed or most likely going to be used as add-in cards, similar to what is the list on x86_64 target. Signed-off-by: Alberto Bursi <alberto.bursi@outlook.it> [fixed whitespace issue] Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--target/linux/x86/generic/profiles/000-Generic.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/x86/generic/profiles/000-Generic.mk b/target/linux/x86/generic/profiles/000-Generic.mk
index 90f989a91d..4760767eee 100644
--- a/target/linux/x86/generic/profiles/000-Generic.mk
+++ b/target/linux/x86/generic/profiles/000-Generic.mk
@@ -7,7 +7,8 @@
define Profile/Generic
NAME:=Generic
- PACKAGES:=kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
+ PACKAGES:=kmod-e1000e kmod-igb kmod-bnx2 \
+ kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
kmod-via-rhine kmod-via-velocity
endef