summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-10-09 06:41:00 +0200
committerPetr Štetiar <ynezz@true.cz>2019-10-09 09:13:44 +0200
commitbd4d3cd1017feb469efa3112d2f92408a420be35 (patch)
tree9b1718dfdd3bcf7f5f3116c31bebb6184054c2d9
parenta9e4e595e1869083aa1027c65a2718567cd6a3bd (diff)
downloadopenwrt-bd4d3cd1017feb469efa3112d2f92408a420be35.tar.gz
openwrt-bd4d3cd1017feb469efa3112d2f92408a420be35.tar.bz2
openwrt-bd4d3cd1017feb469efa3112d2f92408a420be35.zip
toolchain,build: prefer -ffile-prefix-map for gcc-8+
-ffile-prefix-map=OLD=NEW is an alias for both -fdebug-prefix-map and -fmacro-prefix-map and is available since GCC 8. Co-Developed-by: Andre Heider <a.heider@gmail.com> Signed-off-by: Andre Heider <a.heider@gmail.com> Signed-off-by: Paul Spooren <mail@aparcar.org> [refactored into separate commit] Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--rules.mk8
-rw-r--r--toolchain/gcc/Config.in5
-rw-r--r--toolchain/gcc/Config.version5
3 files changed, 9 insertions, 9 deletions
diff --git a/rules.mk b/rules.mk
index f1ca735f2e..fbf42f725d 100644
--- a/rules.mk
+++ b/rules.mk
@@ -140,11 +140,11 @@ else
TOOLCHAIN_DIR_NAME:=toolchain-$(GNU_TARGET_NAME)
endif
-ifeq ($(or $(CONFIG_EXTERNAL_TOOLCHAIN),$(CONFIG_GCC_VERSION_4_8),$(CONFIG_TARGET_uml)),)
- ifeq ($(CONFIG_GCC_USE_EMBEDDED_PATH_REMAP),y)
- iremap = -fmacro-prefix-map=$(1)=$(2)
- else
+ifeq ($(or $(CONFIG_EXTERNAL_TOOLCHAIN),$(CONFIG_TARGET_uml)),)
+ ifeq ($(CONFIG_GCC_USE_IREMAP),y)
iremap = -iremap$(1):$(2)
+ else
+ iremap = -ffile-prefix-map=$(1)=$(2)
endif
endif
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 0977f9b4e7..2c592a904b 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -22,6 +22,11 @@ choice
bool "gcc 9.x"
endchoice
+config GCC_USE_IREMAP
+ default y if ( GCC_USE_VERSION_5 || GCC_USE_VERSION_7 )
+ default n
+ bool
+
config GCC_USE_GRAPHITE
bool
prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index d9732b3e0d..fd8d3873fa 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -11,11 +11,6 @@ config GCC_VERSION_9
default y if GCC_USE_VERSION_9
bool
-config GCC_USE_EMBEDDED_PATH_REMAP
- default y if ( GCC_VERSION_8 || GCC_VERSION_9 )
- default n
- bool
-
config GCC_VERSION
string
default "5.5.0" if GCC_VERSION_5