summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author李国 <uxgood.org@gmail.com>2020-07-25 04:48:36 +0000
committerPaul Spooren <mail@aparcar.org>2021-06-20 13:31:09 -1000
commitca941041366602d4da0bf2c04bb0d3c25ed4fa21 (patch)
tree968121ee2bf245bc54e8113cbed4665b0868a288
parent5876d6a62fc0ae5799e7d9c896356f75c99a6f0a (diff)
downloadopenwrt-ca941041366602d4da0bf2c04bb0d3c25ed4fa21.tar.gz
openwrt-ca941041366602d4da0bf2c04bb0d3c25ed4fa21.tar.bz2
openwrt-ca941041366602d4da0bf2c04bb0d3c25ed4fa21.zip
grub2: make grub2 tools built in a separate variant
grub2 boot-related code and tools-related code may require different compilation parameters. We split them into different variants for compilation, so that we can accurately pass the required parameters and avoid causing problems. Signed-off-by: 李国 <uxgood.org@gmail.com>
-rw-r--r--package/boot/grub2/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/boot/grub2/Makefile b/package/boot/grub2/Makefile
index 709253a935..0610d96e90 100644
--- a/package/boot/grub2/Makefile
+++ b/package/boot/grub2/Makefile
@@ -44,7 +44,7 @@ define Package/grub2-editenv
TITLE:=Grub2 Environment editor
URL:=http://www.gnu.org/software/grub/
DEPENDS:=@TARGET_x86
- VARIANT:=pc
+ VARIANT:=none
endef
define Package/grub2-editenv/description
@@ -58,7 +58,7 @@ define Package/grub2-bios-setup
TITLE:=Grub2 BIOS boot setup tool
URL:=http://www.gnu.org/software/grub/
DEPENDS:=@TARGET_x86
- VARIANT:=pc
+ VARIANT:=none
endef
define Package/grub2-bios-setup/description
@@ -98,6 +98,10 @@ HOST_MAKE_FLAGS += \
TARGET_CFLAGS := $(filter-out -O2 -O3 -fno-plt,$(TARGET_CFLAGS))
+ifneq ($(BUILD_VARIANT),none)
+ MAKE_PATH := grub-core
+endif
+
define Host/Configure
$(SED) 's,(RANLIB),(TARGET_RANLIB),' $(HOST_BUILD_DIR)/grub-core/Makefile.in
$(Host/Configure/Default)