summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2021-06-14 14:58:37 +0200
committerJo-Philipp Wich <jo@mein.io>2021-06-14 15:14:19 +0200
commitf6a03bff5bccdbf9165087bccbb35095903d05c6 (patch)
tree923de69a32d1a284829dfa721b851a186902e278
parent677813c77678b80e99c4f97b433f428de26ca10f (diff)
downloadopenwrt-f6a03bff5bccdbf9165087bccbb35095903d05c6.tar.gz
openwrt-f6a03bff5bccdbf9165087bccbb35095903d05c6.tar.bz2
openwrt-f6a03bff5bccdbf9165087bccbb35095903d05c6.zip
build: prepend ABI suffixes with a dash if package name ends with digit
Ensure that ABI suffixes are separated with a dash from the package name if the name happens to end with a digit. This implementation detail got lost during the recent refactoring of the ABI_VERSION handling in buildroot. Ref: https://github.com/openwrt/packages/pull/14237#issuecomment-860473585 Fixes: c921650382 ("build: drop ABI version from metadata") Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--include/feeds.mk8
-rw-r--r--include/package-ipkg.mk2
2 files changed, 8 insertions, 2 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index 98e315bceb..e499ac2684 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -43,5 +43,11 @@ endef
# 1: package name
define GetABISuffix
-$(if $(filter-out kmod-%,$(1)),$(if $(ABIV_$(1)),$(ABIV_$(1)),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v)))))
+$(call FormatABISuffix,$(1),$(if $(ABIV_$(1)),$(ABIV_$(1)),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v)))))
+endef
+
+# 1: package name
+# 2: abi version
+define FormatABISuffix
+$(if $(filter-out kmod-%,$(1)),$(if $(2),$(if $(filter %0 %1 %2 %3 %4 %5 %6 %7 %8 %9,$(1)),-)$(2)))
endef
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index b066e116f7..19f09c2311 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -99,7 +99,7 @@ _endef=endef
ifeq ($(DUMP),)
define BuildTarget/ipkg
- ABIV_$(1):=$(if $(filter-out kmod-%,$(1)),$(ABI_VERSION))
+ ABIV_$(1):=$(call FormatABISuffix,$(1),$(ABI_VERSION))
PDIR_$(1):=$(call FeedPackageDir,$(1))
IPKG_$(1):=$$(PDIR_$(1))/$(1)$$(ABIV_$(1))_$(VERSION)_$(PKGARCH).ipk
IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg-$(PKGARCH)/$(1)