summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Langer <thomas.langer@intel.com>2018-08-20 12:13:29 +0200
committerJo-Philipp Wich <jo@mein.io>2018-12-18 11:28:11 +0100
commit7772a5b05be1b4970a0e95d4337a28203d6c2efe (patch)
treed0acaad5c0c73cc6332d3cc5f689c4c6d6dd4c6f /Makefile
parent97fddb2fddbf81535f06f168752c9b7e4abaa87a (diff)
downloadopenwrt-7772a5b05be1b4970a0e95d4337a28203d6c2efe.tar.gz
openwrt-7772a5b05be1b4970a0e95d4337a28203d6c2efe.tar.bz2
openwrt-7772a5b05be1b4970a0e95d4337a28203d6c2efe.zip
build: Unset CDPATH to avoid problems
In some places the output of commands, which include "cd" are used. In case of CDPATH the new path is printed, which might not be expected. Disable the variable to avoid these problem. When CDPATH was set by the user to some value like "export CDPATH=." the git checkout done by the build system did not work anymore, the git cloning aborted with such an error message for example: .... Packing checkout... tar: /disk/fs1/tmp2/mehrtens/pon-ugw/ugw-haps/openwrt/tmp/dl/ppa-drv-1.0\n@1534240258: Cannot stat: No such file or directory tar: Date sample file not found Try 'tar --help' or 'tar --usage' for more information. ..... To avoid this, this patch makes the build system unset CDPATH inside the build system, so the build system will still work even when the user set this variable in his local environment. Signed-off-by: Thomas Langer <thomas.langer@intel.com> Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com> Acked-by: Hans Dedecker <dedeckeh@gmail.com> (backported from 41faf52b0ffe902381e75a35e886f635321347b5)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e38d44a810..5301883061 100644
--- a/Makefile
+++ b/Makefile
@@ -27,6 +27,8 @@ ifneq ($(OPENWRT_BUILD),1)
export OPENWRT_BUILD
GREP_OPTIONS=
export GREP_OPTIONS
+ CDPATH=
+ export CDPATH
include $(TOPDIR)/include/debug.mk
include $(TOPDIR)/include/depends.mk
include $(TOPDIR)/include/toplevel.mk