summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-04-19 19:09:11 +0200
committerMathias Kresin <dev@kresin.me>2018-04-19 19:15:00 +0200
commit38bd4e4eb52002045134d00b9d3b0ab8d9d70cc4 (patch)
tree1f3deb0678daa7845c963409f5f708ecb7d560bc /include/image-commands.mk
parentfdf2e1fe1e952ff0c26da1e715d3f414f192dd9f (diff)
downloadopenwrt-38bd4e4eb52002045134d00b9d3b0ab8d9d70cc4.tar.gz
openwrt-38bd4e4eb52002045134d00b9d3b0ab8d9d70cc4.tar.bz2
openwrt-38bd4e4eb52002045134d00b9d3b0ab8d9d70cc4.zip
build: fix uImage fake header command
Use a syntax compatible with mkimage from u-boot 2018.03 to fix the build errors spotted by the build bot. The images are binary identical to the ones generated with mkimage from u-boot 2014.10. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 0f9ac0836c..5f7845a6d9 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -80,10 +80,11 @@ endef
# append a fake/empty rootfs uImage header, to fool the bootloaders
# rootfs integrity check
define Build/append-uImage-fakeroot-hdr
- rm -f $@.fakeroot
+ touch $@.fakeroot
$(STAGING_DIR_HOST)/bin/mkimage \
-A $(LINUX_KARCH) -O linux -T filesystem -C none \
-n '$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) fakeroot' \
+ -d $@.fakeroot \
-s \
$@.fakeroot
cat $@.fakeroot >> $@