summaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2016-10-31 10:14:10 +0200
committerJo-Philipp Wich <jo@mein.io>2017-01-03 14:32:35 +0100
commit15d8d9c271507cd272b264e0bf9deb20030723a2 (patch)
treef46f490d2fe8cbd1bb150ce04bc28aa1ef0fc07b /include/unpack.mk
parent0bb474652e92547156228f389b483cfea96585f5 (diff)
downloadopenwrt-15d8d9c271507cd272b264e0bf9deb20030723a2.tar.gz
openwrt-15d8d9c271507cd272b264e0bf9deb20030723a2.tar.bz2
openwrt-15d8d9c271507cd272b264e0bf9deb20030723a2.zip
build: drop `trapret` function from non-Linux HOST_TAR variant
Looks like this was meant to workaround some limitations with non-GNU tar variants (like BSD-tar which are present on Mac os BSD hosts). Though, I cannot find any use of that `+s` option that's mentioned in the comment. Last hash of this I found was 24faf55360271cd0bfc4751753384f9210d52f7f In my case, it now this fails for `python-setuptools` on Mac OS X (the host-build with): ``` trapret 2 tar -C <home-dir>/work/sources-work/lede/build_dir/target-i386_pentium4_musl-1.1.15/python-setuptools-27.2.0 --strip-components=1 -xzf <home-dir>/work/sources-work/lede/dl/setuptools-27.2.0.tar.gz bash: trapret: command not found ``` So, I was thinking maybe it's time to remove this workaround (9 years later). I could also fix the `python-setuptools` host build. If that's more preferred. [ Btw, I just recently transitioned to a Mac machine for dev-ing, so a lot of (this Mac) stuff I'm finding out is new to me too. ] Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk7
1 files changed, 1 insertions, 6 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index 3fabf46033..41ff439242 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -5,12 +5,7 @@
# See /LICENSE for more information.
#
-# unpacking files with +s may break on some platforms. this typically emits error code 2
-ifneq ($(HOST_OS),Linux)
- HOST_TAR:=trapret 2 $(TAR)
-else
- HOST_TAR:=$(TAR)
-endif
+HOST_TAR:=$(TAR)
TAR_CMD=$(HOST_TAR) -C $(1)/.. $(TAR_OPTIONS)
UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)