summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-05-18 23:10:49 +0300
committerPaul Spooren <mail@aparcar.org>2024-05-18 23:15:22 +0300
commit52a225cba41f72f0e38958a77bcbc5353ccaa731 (patch)
treedd5a641f8181305f90324b717646cfb3bff2e8d2 /include
parent99636d4dd8d4bda15b9e072d2d92dd5f4ae0580f (diff)
downloadopenwrt-52a225cba41f72f0e38958a77bcbc5353ccaa731.tar.gz
openwrt-52a225cba41f72f0e38958a77bcbc5353ccaa731.tar.bz2
openwrt-52a225cba41f72f0e38958a77bcbc5353ccaa731.zip
rootfs: fix USE_APK detection
Due to missing quotes the script would wrongly assume APK to be enabled and don't run post install scripts, breaking pretty much everything. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include')
-rw-r--r--include/rootfs.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index eb4fa434a3..907a95a794 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -78,7 +78,7 @@ define prepare_rootfs
@mkdir -p $(1)/var/lock
@( \
cd $(1); \
- if [ -n $(CONFIG_USE_APK) ]; then \
+ if [ -n "$(CONFIG_USE_APK)" ]; then \
$(STAGING_DIR_HOST)/bin/tar -xf ./lib/apk/db/scripts.tar --wildcards "*.post-install" -O > script.sh; \
chmod +x script.sh; \
IPKG_INSTROOT=$(1) $$(command -v bash) script.sh; \