summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2024-05-03 14:49:58 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-05-03 14:53:11 +0200
commitfc221b065a94dbd9c11218a777a86c1bcdc69ee5 (patch)
treec0caffba785773b4631fe86200fd1145d2f80722 /include
parent23de46c913912cf8695328e966bc47cc57a6e09f (diff)
downloadopenwrt-fc221b065a94dbd9c11218a777a86c1bcdc69ee5.tar.gz
openwrt-fc221b065a94dbd9c11218a777a86c1bcdc69ee5.tar.bz2
openwrt-fc221b065a94dbd9c11218a777a86c1bcdc69ee5.zip
bpf: fix broken inclusion of system include
Commit d82c5884c616 ("treewide: make use of new toolchain define") changed $(TOOLCHAIN_DIR)/include to the new variable $(TOOLCHAIN_INC_DIRS) that now can contain multiple entry. Because of this only the first include in $(TOOLCHAIN_INC_DIRS) was actually included with -isystem, making the other producing warning with ignored inputs. Fix this by parsing each entry in $(TOOLCHAIN_INC_DIRS) and adding the -isystem prefix to correctly include them in the BPF_KERNEL_INCLUDE. Fixes: d82c5884c616 ("treewide: make use of new toolchain define") Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/bpf.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/bpf.mk b/include/bpf.mk
index a3357f0e29..9abc660123 100644
--- a/include/bpf.mk
+++ b/include/bpf.mk
@@ -33,7 +33,7 @@ BPF_TARGET:=bpf$(if $(CONFIG_BIG_ENDIAN),eb,el)
BPF_HEADERS_DIR:=$(STAGING_DIR)/bpf-headers
BPF_KERNEL_INCLUDE := \
- -nostdinc -isystem $(TOOLCHAIN_INC_DIRS) \
+ -nostdinc $(patsubst %,-isystem %,$(TOOLCHAIN_INC_DIRS)) \
-I$(BPF_HEADERS_DIR)/arch/$(BPF_KARCH)/include \
-I$(BPF_HEADERS_DIR)/arch/$(BPF_KARCH)/include/asm/mach-generic \
-I$(BPF_HEADERS_DIR)/arch/$(BPF_KARCH)/include/generated \