summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-08-30 08:45:39 +0200
committerPetr Štetiar <ynezz@true.cz>2022-09-21 11:52:40 +0200
commit1c8c84620de64b20921873c998e93f72dbaccd2a (patch)
treedef4bc2b44983d4d1a8cd4e1fabcd33c913b68c6 /include
parent45a486bf934dc6ddbc71ed4b986a47883df12150 (diff)
downloadopenwrt-1c8c84620de64b20921873c998e93f72dbaccd2a.tar.gz
openwrt-1c8c84620de64b20921873c998e93f72dbaccd2a.tar.bz2
openwrt-1c8c84620de64b20921873c998e93f72dbaccd2a.zip
build: provide xxd -i with scripts/xxdi.pl
Dependency on xxd was added in commit c4dd2441e787 ("tools: add xxd (from vim)") as U-Boot requires xxd to create the default environment from an external file. Later in commit 2b94aac7a128 ("tools: xxd: use more convenient source tarball"), xxd from another source was used instead, but that source is currently unavailable, so let's fix it by using simple xxdi.pl Perl script instead. Fixes: #10555 Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit eae2fb8027cb892e42181e471ba344aa5d26bf7e)
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index d3593b0205..61cd8ae516 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -192,7 +192,10 @@ $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
mkdir -p $(dir $@)
$(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<
-prereq: $(STAGING_DIR_HOST)/bin/mkhash
+$(STAGING_DIR_HOST)/bin/xxd: $(SCRIPT_DIR)/xxdi.pl
+ $(LN) $< $@
+
+prereq: $(STAGING_DIR_HOST)/bin/mkhash $(STAGING_DIR_HOST)/bin/xxd
# Install ldconfig stub
$(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \