summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2021-10-01 15:56:27 -1000
committerPaul Spooren <mail@aparcar.org>2021-10-08 16:32:23 -1000
commit913403b587451abaaf67e8f9640f0dc2cdcec95d (patch)
treecee488b75b1a0131a86e46b03219af864ddf7c77 /include
parente604873e8a66697fd8728d7896a4a715d85182fb (diff)
downloadopenwrt-913403b587451abaaf67e8f9640f0dc2cdcec95d.tar.gz
openwrt-913403b587451abaaf67e8f9640f0dc2cdcec95d.tar.bz2
openwrt-913403b587451abaaf67e8f9640f0dc2cdcec95d.zip
build: fix `which` detection on Fedora & MacOS
Fix Fedora 34/35 issue where 'which' detection of 'which' wasn't working because Fedora use alias and proc Fixup of fca5ad55d2 prereq-build: fix `which` detection on Fedora Reported-by: Jani Partanen <rtfm@iki.fi> Suggest-by: Etienne Champetier <champetier.etienne@gmail.com> Tested-by: Georgi Valkov <gvalkov@abv.bg> Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 0d1ebf0d6d20f0439ab45b293f9daa7662c44ba6)
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 538aee58fe..623881c93f 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -182,7 +182,9 @@ $(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
rsync --version </dev/null))
$(eval $(call SetupHostCommand,which,Please install 'which', \
- which which | grep which))
+ /usr/bin/which which, \
+ /bin/which which, \
+ which which))
$(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
mkdir -p $(dir $@)