summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2021-09-28 15:03:24 +0200
committerPaul Spooren <mail@aparcar.org>2021-10-08 16:34:51 -1000
commit9b258f220f1223dc578e1cfe3ff026fb98b9edd2 (patch)
treea06cad0db016ec90d548a68b53ec74987e4096cc /include
parent913403b587451abaaf67e8f9640f0dc2cdcec95d (diff)
downloadopenwrt-9b258f220f1223dc578e1cfe3ff026fb98b9edd2.tar.gz
openwrt-9b258f220f1223dc578e1cfe3ff026fb98b9edd2.tar.bz2
openwrt-9b258f220f1223dc578e1cfe3ff026fb98b9edd2.zip
prereq-build: recognize Python 3.10
Fedora 35 contains Python 3.10 as default version. Make use of it. Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl> [fix commit subject] Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit e1c03ca18519f9683f6bfce1795e58d99575d895)
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 623881c93f..8b6413564d 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -153,6 +153,7 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
$(eval $(call CleanupPython2))
$(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+ python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
@@ -161,6 +162,7 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+ python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \