summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2022-06-15 12:36:36 +0200
committerRafał Miłecki <rafal@milecki.pl>2022-07-08 15:38:42 +0200
commitb0968be02e264876e79e297d984ec82262344e7a (patch)
tree9997f5f3b25b9f3b38d765aa2cfe9cefe2fb0a37 /include
parent44fa330a8254893ec81e5b3df16299f32a0f053f (diff)
downloadopenwrt-b0968be02e264876e79e297d984ec82262344e7a.tar.gz
openwrt-b0968be02e264876e79e297d984ec82262344e7a.tar.bz2
openwrt-b0968be02e264876e79e297d984ec82262344e7a.zip
kernel: support setting extra CFLAGS for kernel compilation
They may be used e.g. to optimize kernel size or performance. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit 907d7d747243044f86588f0d82993e8c106cb02c)
Diffstat (limited to 'include')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 5057d8bf6f..070d1bca75 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -101,7 +101,7 @@ endif
KERNEL_MAKE = $(MAKE) $(KERNEL_MAKEOPTS)
KERNEL_MAKE_FLAGS = \
- KCFLAGS="$(call iremap,$(BUILD_DIR),$(notdir $(BUILD_DIR))) $(filter-out -fno-plt,$(call qstrip,$(CONFIG_EXTRA_OPTIMIZATION)))" \
+ KCFLAGS="$(call iremap,$(BUILD_DIR),$(notdir $(BUILD_DIR))) $(filter-out -fno-plt,$(call qstrip,$(CONFIG_EXTRA_OPTIMIZATION))) $(call qstrip,$(CONFIG_KERNEL_CFLAGS))" \
HOSTCFLAGS="$(HOST_CFLAGS) -Wall -Wmissing-prototypes -Wstrict-prototypes" \
CROSS_COMPILE="$(KERNEL_CROSS)" \
ARCH="$(LINUX_KARCH)" \