summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-03-22 20:16:15 +0100
committerJo-Philipp Wich <jo@mein.io>2017-12-13 14:56:57 +0100
commit0aafbf6c004879de08932dcb002aceb480a36580 (patch)
tree7191606956fb21ff098005c1b8a074343558a4e5 /include
parent80304ace5891b56ac07e6e64129c74b961f0b4db (diff)
downloadopenwrt-0aafbf6c004879de08932dcb002aceb480a36580.tar.gz
openwrt-0aafbf6c004879de08932dcb002aceb480a36580.tar.bz2
openwrt-0aafbf6c004879de08932dcb002aceb480a36580.zip
build: fix STAMP_PREPARED with quilt
quilt.mk needs to be included first, to ensure that STAMP_PREPARED does not include the hash if quilt is used. Signed-off-by: Felix Fietkau <nbd@nbd.name> (cherry picked from commit 89118da865a34ed9537a088196d81ca9e37cb983)
Diffstat (limited to 'include')
-rw-r--r--include/host-build.mk2
-rw-r--r--include/package.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index cb4d45e9c1..5fcec7ebf4 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -22,6 +22,7 @@ endif
include $(INCLUDE_DIR)/host.mk
include $(INCLUDE_DIR)/unpack.mk
include $(INCLUDE_DIR)/depends.mk
+include $(INCLUDE_DIR)/quilt.mk
BUILD_TYPES += host
HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(HOST_QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPENDS),)))
@@ -32,7 +33,6 @@ HOST_STAMP_INSTALLED:=$(HOST_BUILD_PREFIX)/stamp/.$(PKG_NAME)_installed
override MAKEFLAGS=
-include $(INCLUDE_DIR)/quilt.mk
include $(INCLUDE_DIR)/autotools.mk
Host/Patch:=$(Host/Patch/Default)
diff --git a/include/package.mk b/include/package.mk
index 3248517657..e9989ab13e 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -40,6 +40,7 @@ include $(INCLUDE_DIR)/prereq.mk
include $(INCLUDE_DIR)/host.mk
include $(INCLUDE_DIR)/unpack.mk
include $(INCLUDE_DIR)/depends.mk
+include $(INCLUDE_DIR)/quilt.mk
find_library_dependencies = $(wildcard $(patsubst %,$(STAGING_DIR)/pkginfo/%.version, \
$(filter-out $(BUILD_PACKAGES),$(foreach dep, \
@@ -89,7 +90,6 @@ endif
PKG_INSTALL_STAMP:=$(PKG_INFO_DIR)/$(PKG_DIR_NAME).$(if $(BUILD_VARIANT),$(BUILD_VARIANT),default).install
-include $(INCLUDE_DIR)/quilt.mk
include $(INCLUDE_DIR)/package-defaults.mk
include $(INCLUDE_DIR)/package-dumpinfo.mk
include $(INCLUDE_DIR)/package-ipkg.mk