summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorSven Eckelmann <sven.eckelmann@open-mesh.com>2017-11-30 14:30:06 +0100
committerMathias Kresin <dev@kresin.me>2018-01-13 07:58:47 +0100
commita28bf67c2643a9fe19f561d08002e0e30ed52a17 (patch)
treebe0b12993699f7c1bc30de613314fbed9d2122d7 /include
parent1a384ac0b553433dd5049068e70425c421b796f8 (diff)
downloadopenwrt-a28bf67c2643a9fe19f561d08002e0e30ed52a17.tar.gz
openwrt-a28bf67c2643a9fe19f561d08002e0e30ed52a17.tar.bz2
openwrt-a28bf67c2643a9fe19f561d08002e0e30ed52a17.zip
build: add image command for CE images
Combined Extended Images V1 can be created easily via the new image commands using IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | combined-ext-image Signed-off-by: Sven Eckelmann <sven.eckelmann@open-mesh.com>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 5f0ac6164d..bcc1256df8 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -229,6 +229,19 @@ define Build/combined-image
@mv $@.new $@
endef
+define Build/openmesh-image
+ $(TOPDIR)/scripts/om-fwupgradecfg-gen.sh \
+ "$(call param_get_default,ce_type,$(1),$(DEVICE_NAME))" \
+ "$@-fwupgrade.cfg" \
+ "$(call param_get_default,kernel,$(1),$(IMAGE_KERNEL))" \
+ "$(call param_get_default,rootfs,$(1),$@)"
+ $(TOPDIR)/scripts/combined-ext-image.sh \
+ "$(call param_get_default,ce_type,$(1),$(DEVICE_NAME))" "$@" \
+ "$@-fwupgrade.cfg" "fwupgrade.cfg" \
+ "$(call param_get_default,kernel,$(1),$(IMAGE_KERNEL))" "kernel" \
+ "$(call param_get_default,rootfs,$(1),$@)" "rootfs"
+endef
+
define Build/sysupgrade-tar
sh $(TOPDIR)/scripts/sysupgrade-tar.sh \
--board $(if $(BOARD_NAME),$(BOARD_NAME),$(DEVICE_NAME)) \