summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-03-12 12:55:41 -1000
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-30 22:12:58 +0200
commit3572711e3cea24dd5276666860f57a2c3a72525e (patch)
tree525bcfd9f5f402631120d052d986c2b71a2caf67 /include
parentb7bac0737e3227d1b581efc9f8951fcdf7391e6f (diff)
downloadopenwrt-3572711e3cea24dd5276666860f57a2c3a72525e.tar.gz
openwrt-3572711e3cea24dd5276666860f57a2c3a72525e.tar.bz2
openwrt-3572711e3cea24dd5276666860f57a2c3a72525e.zip
build: refactor JSON info files to `profiles.json`
JSON info files contain machine readable information of built profiles and resulting images. These files were added in commit 881ed09ee6e2 ("build: create JSON files containing image info"). They are useful for firmware wizards and script checking for reproducibility. Currently all JSON files are stored next to the built images, resulting in up to 168 individual files for the ath79/generic target. This patch refactors the JSON creation to store individual per image (not per profile) files in $(BUILD_DIR)/json_info_files and create an single overview file called `profiles.json` in the target directory. Storing per image files and not per profile solves the problem of parallel file writes. If a profiles sysupgrade and factory image are finished at the same time both processes would write to the same JSON file, resulting in randomly broken outputs. Some target like x86/64 do not use the image code yet, resulting in missing JSON files. If no JSON info files were created, no `profiles.json` files is created as it would be empty anyway. As before, this creation is enabled by default only if `BUILDBOT` is set. Tested via buildroot & ImageBuilder on ath79/generic, imx6 and x86/64. Signed-off-by: Paul Spooren <mail@aparcar.org> [json_info_files dir handling in Make, if case refactoring] Signed-off-by: Petr Štetiar <ynezz@true.cz> (backported from commit 07449f692ce4c4525e946401f4c3ed0cbbc8c4df) Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'include')
-rw-r--r--include/image.mk37
1 files changed, 20 insertions, 17 deletions
diff --git a/include/image.mk b/include/image.mk
index 1e0177c439..15f4fe9d3b 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -501,8 +501,11 @@ endef
define Device/Build/image
GZ_SUFFIX := $(if $(filter %dtb %gz,$(2)),,$(if $(and $(findstring ext4,$(1)),$(CONFIG_TARGET_IMAGES_GZIP)),.gz))
- $$(_TARGET): $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2))$$(GZ_SUFFIX)
+ $$(_TARGET): $(if $(CONFIG_JSON_OVERVIEW_IMAGE_INFO), \
+ $(BUILD_DIR)/json_info_files/$(call IMAGE_NAME,$(1),$(2)).json, \
+ $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2))$$(GZ_SUFFIX))
$(eval $(call Device/Export,$(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)),$(1)))
+
ROOTFS/$(1)/$(3) := \
$(KDIR)/root.$(1)$$(strip \
$$(if $$(FS_OPTIONS/$(1)),+fs=$$(call param_mangle,$$(FS_OPTIONS/$(1)))) \
@@ -524,20 +527,21 @@ define Device/Build/image
$(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2)): $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2))
cp $$^ $$@
- $(if $(CONFIG_JSON_ADD_IMAGE_INFO), \
- DEVICE_ID="$(DEVICE_NAME)" \
- BIN_DIR="$(BIN_DIR)" \
- IMAGE_NAME="$(IMAGE_NAME)" \
- IMAGE_TYPE=$(word 1,$(subst ., ,$(2))) \
- IMAGE_PREFIX="$(IMAGE_PREFIX)" \
- DEVICE_TITLE="$(DEVICE_TITLE)" \
- TARGET="$(BOARD)" \
- SUBTARGET="$(SUBTARGET)" \
- VERSION_NUMBER="$(VERSION_NUMBER)" \
- VERSION_CODE="$(VERSION_CODE)" \
- SUPPORTED_DEVICES="$(SUPPORTED_DEVICES)" \
- $(TOPDIR)/scripts/json_add_image_info.py \
- )
+
+ $(BUILD_DIR)/json_info_files/$(call IMAGE_NAME,$(1),$(2)).json: $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2))$$(GZ_SUFFIX)
+ @mkdir -p $$(shell dirname $$@)
+ DEVICE_ID="$(DEVICE_NAME)" \
+ BIN_DIR="$(BIN_DIR)" \
+ IMAGE_NAME="$(IMAGE_NAME)" \
+ IMAGE_TYPE=$(word 1,$(subst ., ,$(2))) \
+ IMAGE_PREFIX="$(IMAGE_PREFIX)" \
+ DEVICE_TITLE="$(DEVICE_TITLE)" \
+ TARGET="$(BOARD)" \
+ SUBTARGET="$(if $(SUBTARGET),$(SUBTARGET),generic)" \
+ VERSION_NUMBER="$(VERSION_NUMBER)" \
+ VERSION_CODE="$(VERSION_CODE)" \
+ SUPPORTED_DEVICES="$(SUPPORTED_DEVICES)" \
+ $(TOPDIR)/scripts/json_add_image_info.py $$@
endef
@@ -556,8 +560,6 @@ define Device/Build/artifact
endef
define Device/Build
- $(shell rm -f $(BIN_DIR)/$(IMG_PREFIX)-$(1).json)
-
$(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),$(call Device/Build/initramfs,$(1)))
$(call Device/Build/kernel,$(1))
@@ -626,6 +628,7 @@ define BuildImage
image_prepare: compile
mkdir -p $(BIN_DIR) $(KDIR)/tmp
+ rm -rf $(BUILD_DIR)/json_info_files
$(call Image/Prepare)
legacy-images-prepare-make: image_prepare