summaryrefslogtreecommitdiffstats
path: root/package/boot/at91bootstrap/Makefile
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2018-05-04 10:27:51 -0700
committerJohn Crispin <john@phrozen.org>2018-05-05 06:55:22 +0200
commit27ca6cdc7bb3e01d12ed4cf6a3cc5b2b11c516de (patch)
treec45a3a4b9fada7c1cf3f2966b8d9afdfa14e65b3 /package/boot/at91bootstrap/Makefile
parent60750ab505bae8d1cb70c6fe495b755b213a1ebf (diff)
downloadopenwrt-27ca6cdc7bb3e01d12ed4cf6a3cc5b2b11c516de.tar.gz
openwrt-27ca6cdc7bb3e01d12ed4cf6a3cc5b2b11c516de.tar.bz2
openwrt-27ca6cdc7bb3e01d12ed4cf6a3cc5b2b11c516de.zip
at91: Add SAMA5D2 PTC EK board
Add target device as at91-sama5d2_ptc_ek in SAMA5D2 subtarget and build images for SAMA5D2 PTC Ek board. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'package/boot/at91bootstrap/Makefile')
-rw-r--r--package/boot/at91bootstrap/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index b350555c10..22afd1ec41 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -94,6 +94,18 @@ define AT91Bootstrap/sama5d27_som1_ekqspi_uboot
BUILD_DEVICES:=at91-sama5d27_som1_ek
endef
+define AT91Bootstrap/sama5d2_ptc_eknf_uboot
+ TITLE:=AT91Bootstrap for SAMA5D2 PTC EK (Nand Flash)
+ BUILD_SUBTARGET:=sama5d2
+ BUILD_DEVICES:=at91-sama5d2_ptc_ek
+endef
+
+define AT91Bootstrap/sama5d2_ptc_eksd_uboot
+ TITLE:=AT91Bootstrap for SAMA5D2 PTC EK (SDCard)
+ BUILD_SUBTARGET:=sama5d2
+ BUILD_DEVICES:=at91-sama5d2_ptc_ek
+endef
+
AT91BOOTSTRAP_TARGETS := \
sama5d2_xplaineddf_uboot \
sama5d2_xplaineddf_qspi_uboot \
@@ -104,7 +116,9 @@ AT91BOOTSTRAP_TARGETS := \
sama5d4_xplaineddf_uboot_secure \
sama5d4_xplainedsd_uboot_secure \
sama5d27_som1_eksd_uboot \
- sama5d27_som1_ekqspi_uboot
+ sama5d27_som1_ekqspi_uboot \
+ sama5d2_ptc_eknf_uboot \
+ sama5d2_ptc_eksd_uboot
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \