summaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2024-03-18 11:42:42 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2024-05-25 20:18:23 +0200
commit35efee132963b0c3211e14ea68e79721561de195 (patch)
tree7a1a13e88e10e467055c2d9227c004be88110653 /package/boot
parent322f2c14246d1c84cb5c8a0247cf9457e61ac435 (diff)
downloadopenwrt-35efee132963b0c3211e14ea68e79721561de195.tar.gz
openwrt-35efee132963b0c3211e14ea68e79721561de195.tar.bz2
openwrt-35efee132963b0c3211e14ea68e79721561de195.zip
uboot-layerscape: bump to lf-6.6.3-1.0.0
This commit bumps u-boot layerscape package to lf-6.6.3-1.0.0 version. Removed upstreamed: 0001-board-ls1046ardb-force-PCI-device-enumeration.patch 0002-board-ls1043ardb-force-PCI-device-enumeration.patch Manually rebased: 0900-layerscape-adjust-LS1021A-IOT-config-for-OpenWrt.patch Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/uboot-layerscape/Makefile9
-rw-r--r--package/boot/uboot-layerscape/patches/0001-board-ls1046ardb-force-PCI-device-enumeration.patch33
-rw-r--r--package/boot/uboot-layerscape/patches/0002-board-ls1043ardb-force-PCI-device-enumeration.patch34
-rw-r--r--package/boot/uboot-layerscape/patches/0900-layerscape-adjust-LS1021A-IOT-config-for-OpenWrt.patch40
4 files changed, 25 insertions, 91 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index 8c5e32587d..722f4f30b7 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-layerscape
-PKG_VERSION:=lf-6.1.1-1.0.0
+PKG_VERSION:=6.6.3.1.0.0
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/nxp-qoriq/u-boot
-PKG_SOURCE_VERSION:=lf-6.1.1-1.0.0
-PKG_MIRROR_HASH:=6cb3cd569f11f582375eb3af475a2a0d77fe602813337b64883ef01344be7bf6
+PKG_SOURCE_VERSION:=lf-6.6.3-1.0.0
+PKG_MIRROR_HASH:=dec5b6e4fe328b930f201fbf06a0a7b71a9dd72f38f16c9570188c0a7fea916a
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
@@ -30,19 +30,16 @@ endef
define U-Boot/fsl_ls1012a-frdm
NAME:=NXP LS1012AFRDM
UBOOT_CONFIG:=ls1012afrdm_tfa
- ENV_SIZE:=0x40000
endef
define U-Boot/fsl_ls1012a-rdb
NAME:=NXP LS1012ARDB
UBOOT_CONFIG:=ls1012ardb_tfa
- ENV_SIZE:=0x40000
endef
define U-Boot/fsl_ls1012a-frwy-sdboot
NAME:=NXP LS1012AFRWY
UBOOT_CONFIG:=ls1012afrwy_tfa
- ENV_SIZE:=0x10000
endef
define U-Boot/fsl_ls1028a-rdb
diff --git a/package/boot/uboot-layerscape/patches/0001-board-ls1046ardb-force-PCI-device-enumeration.patch b/package/boot/uboot-layerscape/patches/0001-board-ls1046ardb-force-PCI-device-enumeration.patch
deleted file mode 100644
index 25a6b16363..0000000000
--- a/package/boot/uboot-layerscape/patches/0001-board-ls1046ardb-force-PCI-device-enumeration.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 089b90b11008ec95a56da12e31d11e3f31a9bb26 Mon Sep 17 00:00:00 2001
-From: Martin Schiller <ms@dev.tdt.de>
-Date: Wed, 17 Nov 2021 07:29:55 +0100
-Subject: [PATCH] board: ls1046ardb: force PCI device enumeration
-
-Commit 045ecf899252 ("configs: enable DM_ETH support for LS1046ARDB")
-resulted in the PCI bus no longer being implicitly enumerated.
-
-However, this is necessary for the fdt pcie fixups to work.
-
-Therefore, similar to commit 8b6558bd4187 ("board: ls1088ardb:
-transition to DM_ETH"), pci_init() is now called in the board_init()
-routine when CONFIG_DM_ETH is active.
-
-Signed-off-by: Martin Schiller <ms@dev.tdt.de>
-CC: Priyanka Jain <priyanka.jain@nxp.com>
----
- board/freescale/ls1046ardb/ls1046ardb.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
---- a/board/freescale/ls1046ardb/ls1046ardb.c
-+++ b/board/freescale/ls1046ardb/ls1046ardb.c
-@@ -88,6 +88,10 @@ int board_init(void)
- ppa_init();
- #endif
-
-+#if !defined(CONFIG_SYS_EARLY_PCI_INIT) && defined(CONFIG_DM_ETH)
-+ pci_init();
-+#endif
-+
- /* invert AQR105 IRQ pins polarity */
- out_be32(&scfg->intpcr, AQR105_IRQ_MASK);
-
diff --git a/package/boot/uboot-layerscape/patches/0002-board-ls1043ardb-force-PCI-device-enumeration.patch b/package/boot/uboot-layerscape/patches/0002-board-ls1043ardb-force-PCI-device-enumeration.patch
deleted file mode 100644
index d38102a13c..0000000000
--- a/package/boot/uboot-layerscape/patches/0002-board-ls1043ardb-force-PCI-device-enumeration.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 64d2dffa8b51c1beb7e472690dcac965ac0f7ac4 Mon Sep 17 00:00:00 2001
-From: Martin Schiller <ms@dev.tdt.de>
-Date: Tue, 23 Nov 2021 07:24:19 +0100
-Subject: [PATCH] board: ls1043ardb: force PCI device enumeration
-
-Commit eb1986804d1d ("configs: enable DM_ETH support for LS1043ARDB")
-resulted in the PCI bus no longer being implicitly enumerated.
-
-However, this is necessary for the fdt pcie fixups to work.
-
-Therefore, similar to commit 8b6558bd4187 ("board: ls1088ardb:
-transition to DM_ETH"), pci_init() is now called in the board_init()
-routine when CONFIG_DM_ETH is active.
-
-Signed-off-by: Martin Schiller <ms@dev.tdt.de>
-CC: Priyanka Jain <priyanka.jain@nxp.com>
-CC: Camelia Groza <camelia.groza@nxp.com>
----
- board/freescale/ls1043ardb/ls1043ardb.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
---- a/board/freescale/ls1043ardb/ls1043ardb.c
-+++ b/board/freescale/ls1043ardb/ls1043ardb.c
-@@ -214,6 +214,10 @@ int board_init(void)
- ppa_init();
- #endif
-
-+#if !defined(CONFIG_SYS_EARLY_PCI_INIT) && defined(CONFIG_DM_ETH)
-+ pci_init();
-+#endif
-+
- #ifdef CONFIG_U_QE
- u_qe_init();
- #endif
diff --git a/package/boot/uboot-layerscape/patches/0900-layerscape-adjust-LS1021A-IOT-config-for-OpenWrt.patch b/package/boot/uboot-layerscape/patches/0900-layerscape-adjust-LS1021A-IOT-config-for-OpenWrt.patch
index 414f2541ac..fbd96c0fa9 100644
--- a/package/boot/uboot-layerscape/patches/0900-layerscape-adjust-LS1021A-IOT-config-for-OpenWrt.patch
+++ b/package/boot/uboot-layerscape/patches/0900-layerscape-adjust-LS1021A-IOT-config-for-OpenWrt.patch
@@ -1,4 +1,4 @@
-From b382eeafe01df21da3518b2f1dd7d22ee114efb0 Mon Sep 17 00:00:00 2001
+From 54a19a8c97608c71b440639c878f2f57b5add95d Mon Sep 17 00:00:00 2001
From: Pawel Dembicki <paweldembicki@gmail.com>
Date: Mon, 24 Oct 2022 14:19:38 +0200
Subject: [PATCH] layerscape: adjust LS1021A-IOT config for OpenWrt
@@ -12,13 +12,30 @@ Let's enable it. U-boot is now bigger than 512K. Let's enlarge it to
Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
---
- configs/ls1021aiot_sdcard_defconfig | 3 +++
- include/configs/ls1021aiot.h | 4 ++--
- 2 files changed, 5 insertions(+), 2 deletions(-)
+ configs/ls1021aiot_sdcard_defconfig | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
--- a/configs/ls1021aiot_sdcard_defconfig
+++ b/configs/ls1021aiot_sdcard_defconfig
-@@ -27,8 +27,11 @@ CONFIG_CMD_MII=y
+@@ -24,7 +24,7 @@ CONFIG_AHCI=y
+ CONFIG_LAYERSCAPE_NS_ACCESS=y
+ CONFIG_PCIE1=y
+ CONFIG_PCIE2=y
+-CONFIG_SYS_MONITOR_LEN=524288
++CONFIG_SYS_MONITOR_LEN=786432
+ CONFIG_OF_BOARD_SETUP=y
+ CONFIG_OF_STDOUT_VIA_ALIAS=y
+ CONFIG_RAMBOOT_PBL=y
+@@ -40,7 +40,7 @@ CONFIG_SPL_MAX_SIZE=0x1a000
+ CONFIG_SPL_PAD_TO=0x1c000
+ CONFIG_SPL_HAS_BSS_LINKER_SECTION=y
+ CONFIG_SPL_BSS_START_ADDR=0x80100000
+-CONFIG_SPL_BSS_MAX_SIZE=0x80000
++CONFIG_SPL_BSS_MAX_SIZE=0xc0000
+ CONFIG_SPL_FSL_PBL=y
+ # CONFIG_SPL_SHARES_INIT_SP_ADDR is not set
+ CONFIG_SYS_SPL_MALLOC=y
+@@ -66,8 +66,11 @@ CONFIG_CMD_MII=y
# CONFIG_CMD_MDIO is not set
CONFIG_CMD_PING=y
CONFIG_CMD_EXT2=y
@@ -30,16 +47,3 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
CONFIG_OF_CONTROL=y
CONFIG_ENV_OVERWRITE=y
CONFIG_ENV_IS_IN_MMC=y
---- a/include/configs/ls1021aiot.h
-+++ b/include/configs/ls1021aiot.h
-@@ -78,8 +78,8 @@
- CONFIG_SYS_MONITOR_LEN)
- #define CONFIG_SYS_SPL_MALLOC_SIZE 0x100000
- #define CONFIG_SPL_BSS_START_ADDR 0x80100000
--#define CONFIG_SPL_BSS_MAX_SIZE 0x80000
--#define CONFIG_SYS_MONITOR_LEN 0x80000
-+#define CONFIG_SPL_BSS_MAX_SIZE 0xc0000
-+#define CONFIG_SYS_MONITOR_LEN 0xc0000
- #endif
-
- #define CONFIG_SYS_DDR_SDRAM_BASE 0x80000000UL