summaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-08-27 19:53:17 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-09-02 23:13:53 +0200
commit392febc6f6925903d7367ed870cb97a711554bd5 (patch)
tree64668df2b0e181049cfce91818115667856c2f86 /package/devel
parent728740fe7818ebd3264fcd98b78a0e12239e73aa (diff)
downloadopenwrt-392febc6f6925903d7367ed870cb97a711554bd5.tar.gz
openwrt-392febc6f6925903d7367ed870cb97a711554bd5.tar.bz2
openwrt-392febc6f6925903d7367ed870cb97a711554bd5.zip
gdb: update to 12.1
Release Notes: https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=blob_plain;f=gdb/NEWS;hb=gdb-12.1-release Refresh patches: - 110-shared_libgcc.patch - 130-gdb-ctrl-c.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/gdb/Makefile4
-rw-r--r--package/devel/gdb/patches/110-shared_libgcc.patch12
-rw-r--r--package/devel/gdb/patches/130-gdb-ctrl-c.patch2
3 files changed, 9 insertions, 9 deletions
diff --git a/package/devel/gdb/Makefile b/package/devel/gdb/Makefile
index dd1df7af85..7acf26d60b 100644
--- a/package/devel/gdb/Makefile
+++ b/package/devel/gdb/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gdb
-PKG_VERSION:=11.2
+PKG_VERSION:=12.1
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=1497c36a71881b8671a9a84a0ee40faab788ca30d7ba19d8463c3cc787152e32
+PKG_HASH:=0e1793bf8f2b54d53f46dea84ccfd446f48f81b297b28c4f7fc017b818d69fed
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
diff --git a/package/devel/gdb/patches/110-shared_libgcc.patch b/package/devel/gdb/patches/110-shared_libgcc.patch
index 3979ccd26b..f1602bc695 100644
--- a/package/devel/gdb/patches/110-shared_libgcc.patch
+++ b/package/devel/gdb/patches/110-shared_libgcc.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -1300,13 +1300,13 @@ if test -z "$LD"; then
+@@ -1314,13 +1314,13 @@ if test -z "$LD"; then
fi
fi
@@ -17,7 +17,7 @@
AC_LANG_PUSH(C++)
AC_LINK_IFELSE([AC_LANG_SOURCE([
#if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
-@@ -1705,7 +1705,7 @@ AC_ARG_WITH(stage1-ldflags,
+@@ -1719,7 +1719,7 @@ AC_ARG_WITH(stage1-ldflags,
# trust that they are doing what they want.
if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
-a "$have_static_libs" = yes; then
@@ -26,7 +26,7 @@
fi])
AC_SUBST(stage1_ldflags)
-@@ -1734,7 +1734,7 @@ AC_ARG_WITH(boot-ldflags,
+@@ -1748,7 +1748,7 @@ AC_ARG_WITH(boot-ldflags,
# statically. But if the user explicitly specified the libraries to
# use, trust that they are doing what they want.
if test "$poststage1_libs" = ""; then
@@ -37,7 +37,7 @@
--- a/configure
+++ b/configure
-@@ -5257,14 +5257,14 @@ if test -z "$LD"; then
+@@ -5275,14 +5275,14 @@ if test -z "$LD"; then
fi
fi
@@ -56,7 +56,7 @@
ac_ext=cpp
ac_cpp='$CXXCPP $CPPFLAGS'
ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-@@ -6149,7 +6149,7 @@ else
+@@ -6167,7 +6167,7 @@ else
# trust that they are doing what they want.
if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
-a "$have_static_libs" = yes; then
@@ -65,7 +65,7 @@
fi
fi
-@@ -6185,7 +6185,7 @@ else
+@@ -6203,7 +6203,7 @@ else
# statically. But if the user explicitly specified the libraries to
# use, trust that they are doing what they want.
if test "$poststage1_libs" = ""; then
diff --git a/package/devel/gdb/patches/130-gdb-ctrl-c.patch b/package/devel/gdb/patches/130-gdb-ctrl-c.patch
index 72b7273434..f793a71cae 100644
--- a/package/devel/gdb/patches/130-gdb-ctrl-c.patch
+++ b/package/devel/gdb/patches/130-gdb-ctrl-c.patch
@@ -24,7 +24,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
--- a/gdbserver/linux-low.cc
+++ b/gdbserver/linux-low.cc
-@@ -5733,7 +5733,7 @@ linux_process_target::request_interrupt
+@@ -5496,7 +5496,7 @@ linux_process_target::request_interrupt
{
/* Send a SIGINT to the process group. This acts just like the user
typed a ^C on the controlling terminal. */