summaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2024-03-24 15:43:02 +0100
committerFelix Fietkau <nbd@nbd.name>2024-03-29 15:41:16 +0100
commit87de62dcb8b6d1441749a7e729bdcde46a4ea0dc (patch)
tree8ef1a7f9c50152a94851311ecd27a3d25973b8c2 /package/devel
parent383b68e73cc9f4cdeaa92b2cf7d20142a4a9a9ae (diff)
downloadopenwrt-87de62dcb8b6d1441749a7e729bdcde46a4ea0dc.tar.gz
openwrt-87de62dcb8b6d1441749a7e729bdcde46a4ea0dc.tar.bz2
openwrt-87de62dcb8b6d1441749a7e729bdcde46a4ea0dc.zip
perf: fix build on linux 6.6
- use Makefile.perf to prevent overriding MAKEFLAGS - fix path to PKG_CONFIG - link libstdc++ statically (only used for demangling) Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/perf/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index f9573c4150..27ab7173f8 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -28,7 +28,7 @@ define Package/perf
SECTION:=devel
CATEGORY:=Development
DEPENDS:= +libelf +libdw +PACKAGE_libunwind:libunwind +libpthread +librt +objdump @!IN_SDK @KERNEL_PERF_EVENTS \
- +PACKAGE_libbfd:libbfd +PACKAGE_libopcodes:libopcodes
+ +PACKAGE_libbfd:libbfd +PACKAGE_libopcodes:libopcodes +libtraceevent
TITLE:=Linux performance monitoring tool
VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
URL:=http://www.kernel.org
@@ -63,14 +63,19 @@ MAKE_FLAGS = \
LDFLAGS="$(TARGET_LDFLAGS)" \
KBUILD_HOSTCFLAGS="$(HOST_CFLAGS)" \
$(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
+ PKG_CONFIG="$(PKG_CONFIG)" \
+ PKG_CONFIG_PATH="$(PKG_CONFIG_PATH)" \
+ EXCLUDE_EXTLIBS="-lstdc++" \
+ EXTRA_PERFLIBS="$(shell $(TARGET_CC) -print-file-name=libstdc++.a)" \
WERROR=0 \
O=$(PKG_BUILD_DIR) \
prefix=/usr
define Build/Compile
- +$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
+ +$(MAKE) $(PKG_JOBS) $(MAKE_FLAGS) \
--no-print-directory \
- -C $(LINUX_DIR)/tools/perf
+ -C $(LINUX_DIR)/tools/perf \
+ -f Makefile.perf
endef
define Package/perf/install