summaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2024-02-07 12:52:46 +0100
committerNick Hainke <vincent@systemli.org>2024-02-12 23:41:03 +0100
commita42075435af8d7edf42aa38a02e492a5ea22a208 (patch)
tree0b1df839a0092acf88f9626a8a6538229592ed9a /package/devel
parent6f83a708c8f1df14da9a24609d32bd7263d1798b (diff)
downloadopenwrt-a42075435af8d7edf42aa38a02e492a5ea22a208.tar.gz
openwrt-a42075435af8d7edf42aa38a02e492a5ea22a208.tar.bz2
openwrt-a42075435af8d7edf42aa38a02e492a5ea22a208.zip
binutils: update to 2.42
Refresh patch: - 001-replace-attribute_const.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/binutils/Makefile4
-rw-r--r--package/devel/binutils/patches/001-replace-attribute_const.patch10
2 files changed, 7 insertions, 7 deletions
diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
index 3a54a0be92..3fb281c2ed 100644
--- a/package/devel/binutils/Makefile
+++ b/package/devel/binutils/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=binutils
-PKG_VERSION:=2.41
+PKG_VERSION:=2.42
PKG_RELEASE:=1
PKG_SOURCE_URL:=@GNU/binutils
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_VERSION:=$(PKG_VERSION)
-PKG_HASH:=ae9a5789e23459e59606e6714723f2d3ffc31c03174191ef0d015bdf06007450
+PKG_HASH:=f6e4d41fd5fc778b06b7891457b3620da5ecea1006c6a4a41ae998109f85a800
PKG_FIXUP:=patch-libtool
PKG_LIBTOOL_PATHS:=. gas bfd opcodes gprof gprofng binutils ld libiberty gold intl libctf libsframe
diff --git a/package/devel/binutils/patches/001-replace-attribute_const.patch b/package/devel/binutils/patches/001-replace-attribute_const.patch
index 5fd855efd1..dac641de11 100644
--- a/package/devel/binutils/patches/001-replace-attribute_const.patch
+++ b/package/devel/binutils/patches/001-replace-attribute_const.patch
@@ -28,8 +28,8 @@ unwind.c:490:3: note: in expansion of macro 'FILL_CONTEXT'
unsigned int *ecx ATTRIBUTE_UNUSED, unsigned int *edx ATTRIBUTE_UNUSED)
--- a/gprofng/libcollector/unwind.c
+++ b/gprofng/libcollector/unwind.c
-@@ -233,7 +233,7 @@ memory_error_func (int status ATTRIBUTE_
- #elif ARCH(Aarch64)
+@@ -237,7 +237,7 @@ typedef uint64_t __u64;
+
#define FILL_CONTEXT(context) \
{ CALL_UTIL (getcontext) (context); \
- context->uc_mcontext.sp = (__u64) __builtin_frame_address(0); \
@@ -37,7 +37,7 @@ unwind.c:490:3: note: in expansion of macro 'FILL_CONTEXT'
}
#endif /* ARCH() */
-@@ -4579,11 +4579,11 @@ stack_unwind (char *buf, int size, void
+@@ -4583,11 +4583,11 @@ stack_unwind (char *buf, int size, void
if (buf && bptr && eptr && context && size + mode > 0)
getByteInstruction ((unsigned char *) eptr);
int ind = 0;
@@ -54,7 +54,7 @@ unwind.c:490:3: note: in expansion of macro 'FILL_CONTEXT'
unsigned long tbgn = 0;
unsigned long tend = 0;
-@@ -4594,7 +4594,7 @@ stack_unwind (char *buf, int size, void
+@@ -4598,7 +4598,7 @@ stack_unwind (char *buf, int size, void
{
stack_base = sp + 0x100000;
if (stack_base < sp) // overflow
@@ -63,7 +63,7 @@ unwind.c:490:3: note: in expansion of macro 'FILL_CONTEXT'
}
DprintfT (SP_DUMP_UNWIND,
"unwind.c:%d stack_unwind %2d pc=0x%llx sp=0x%llx stack_base=0x%llx\n",
-@@ -4625,17 +4625,17 @@ stack_unwind (char *buf, int size, void
+@@ -4629,17 +4629,17 @@ stack_unwind (char *buf, int size, void
__LINE__, (unsigned long) sp);
break;
}