summaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2023-12-10 00:08:15 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2024-01-04 22:40:05 +0100
commit4a5d1d0e95d6ec6ac9c9418af9d93a0ad2e7c100 (patch)
tree9f1e8bd7d602e8d88baf3112c967d595637d8bf0 /package/devel
parent309c2cd4fbd2876a144bb4423428363f36c67a3f (diff)
downloadopenwrt-4a5d1d0e95d6ec6ac9c9418af9d93a0ad2e7c100.tar.gz
openwrt-4a5d1d0e95d6ec6ac9c9418af9d93a0ad2e7c100.tar.bz2
openwrt-4a5d1d0e95d6ec6ac9c9418af9d93a0ad2e7c100.zip
devel/gdb: Update to 14.1
Update the gdb package to 14.1 * mpfr is now required, remove the 'without' and add dependency * remove mpc 'without' that is parsed wrongly, causing "-Lno/lib" * refresh patches Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/gdb/Makefile10
-rw-r--r--package/devel/gdb/patches/110-shared_libgcc.patch12
-rw-r--r--package/devel/gdb/patches/130-gdb-ctrl-c.patch2
3 files changed, 11 insertions, 13 deletions
diff --git a/package/devel/gdb/Makefile b/package/devel/gdb/Makefile
index 3efbce28f4..cf897b79f2 100644
--- a/package/devel/gdb/Makefile
+++ b/package/devel/gdb/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gdb
-PKG_VERSION:=13.2
-PKG_RELEASE:=2
+PKG_VERSION:=14.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=fd5bebb7be1833abdb6e023c2f498a354498281df9d05523d8915babeb893f0a
+PKG_HASH:=d66df51276143451fcbff464cc8723d68f1e9df45a6a2d5635a54e71643edb80
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
@@ -33,7 +33,7 @@ endef
define Package/gdb
$(call Package/gdb/Default)
TITLE:=GNU Debugger
- DEPENDS+=+libreadline +libncurses +zlib +libgmp
+ DEPENDS+=+libreadline +libncurses +zlib +libgmp +libmpfr
endef
define Package/gdb/description
@@ -64,8 +64,6 @@ CONFIGURE_ARGS+= \
--disable-sim \
--disable-werror \
--disable-source-highlight \
- --without-mpc \
- --without-mpfr \
--without-isl \
--without-xxhash \
--with-libgmp-prefix=$(STAGING_DIR)/usr
diff --git a/package/devel/gdb/patches/110-shared_libgcc.patch b/package/devel/gdb/patches/110-shared_libgcc.patch
index 44d4ffa77f..1a02ad1160 100644
--- a/package/devel/gdb/patches/110-shared_libgcc.patch
+++ b/package/devel/gdb/patches/110-shared_libgcc.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -1435,13 +1435,13 @@ if test -z "$LD"; then
+@@ -1400,13 +1400,13 @@ if test -z "$LD"; then
fi
fi
@@ -17,7 +17,7 @@
AC_LANG_PUSH(C++)
AC_LINK_IFELSE([AC_LANG_SOURCE([
#if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
-@@ -1838,7 +1838,7 @@ AC_ARG_WITH(stage1-ldflags,
+@@ -1836,7 +1836,7 @@ AC_ARG_WITH(stage1-ldflags,
# trust that they are doing what they want.
if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
-a "$have_static_libs" = yes; then
@@ -26,7 +26,7 @@
fi])
AC_SUBST(stage1_ldflags)
-@@ -1867,7 +1867,7 @@ AC_ARG_WITH(boot-ldflags,
+@@ -1865,7 +1865,7 @@ AC_ARG_WITH(boot-ldflags,
# statically. But if the user explicitly specified the libraries to
# use, trust that they are doing what they want.
if test "$poststage1_libs" = ""; then
@@ -37,7 +37,7 @@
--- a/configure
+++ b/configure
-@@ -5442,14 +5442,14 @@ if test -z "$LD"; then
+@@ -5413,14 +5413,14 @@ if test -z "$LD"; then
fi
fi
@@ -56,7 +56,7 @@
ac_ext=cpp
ac_cpp='$CXXCPP $CPPFLAGS'
ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-@@ -8440,7 +8440,7 @@ else
+@@ -8464,7 +8464,7 @@ else
# trust that they are doing what they want.
if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
-a "$have_static_libs" = yes; then
@@ -65,7 +65,7 @@
fi
fi
-@@ -8476,7 +8476,7 @@ else
+@@ -8500,7 +8500,7 @@ else
# statically. But if the user explicitly specified the libraries to
# use, trust that they are doing what they want.
if test "$poststage1_libs" = ""; then
diff --git a/package/devel/gdb/patches/130-gdb-ctrl-c.patch b/package/devel/gdb/patches/130-gdb-ctrl-c.patch
index 8650ce844c..5272b7e969 100644
--- a/package/devel/gdb/patches/130-gdb-ctrl-c.patch
+++ b/package/devel/gdb/patches/130-gdb-ctrl-c.patch
@@ -24,7 +24,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
--- a/gdbserver/linux-low.cc
+++ b/gdbserver/linux-low.cc
-@@ -5467,7 +5467,7 @@ linux_process_target::request_interrupt
+@@ -5481,7 +5481,7 @@ linux_process_target::request_interrupt
{
/* Send a SIGINT to the process group. This acts just like the user
typed a ^C on the controlling terminal. */