summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-04-01 19:25:42 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-04-06 14:48:46 +0200
commit6541897796752785743657910263324c89dee28d (patch)
tree6c2b0aa695cb487572afca7cc7c51f519efeac40 /package/kernel/linux
parent1b3dda179a6b2ec819aa3f863662c6f00f89c961 (diff)
downloadopenwrt-6541897796752785743657910263324c89dee28d.tar.gz
openwrt-6541897796752785743657910263324c89dee28d.tar.bz2
openwrt-6541897796752785743657910263324c89dee28d.zip
kernel: package rtc-em3027 module
Support for Microelectronic EM3027 real time clock chip. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/other.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 220452df9b..e279616f20 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -528,6 +528,24 @@ endef
$(eval $(call KernelPackage,rtc-ds1672))
+define KernelPackage/rtc-em3027
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Microelectronic EM3027 RTC support
+ DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+ DEPENDS:=+kmod-i2c-core
+ KCONFIG:=CONFIG_RTC_DRV_EM3027 \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-em3027.ko
+ AUTOLOAD:=$(call AutoProbe,rtc-em3027)
+endef
+
+define KernelPackage/rtc-em3027/description
+ Kernel module for Microelectronic EM3027 RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-em3027))
+
+
define KernelPackage/rtc-isl1208
SUBMENU:=$(OTHER_MENU)
TITLE:=Intersil ISL1208 RTC support