summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2019-02-13 12:51:27 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2019-02-24 01:17:01 +0200
commit77a54bbf13bf2a798cfdfc8dd6c61759ac18a19f (patch)
tree6a45ca46e093fadad300227ec90b843283ecf1be /package/kernel/linux
parentc22cde2ea13133a9c75522a03fde225ccfd2770d (diff)
downloadopenwrt-77a54bbf13bf2a798cfdfc8dd6c61759ac18a19f.tar.gz
openwrt-77a54bbf13bf2a798cfdfc8dd6c61759ac18a19f.tar.bz2
openwrt-77a54bbf13bf2a798cfdfc8dd6c61759ac18a19f.zip
kernel: add kmod-input-touchscreen-ads7846
This module adds support for ADS7846 based touchscreens used in devices like the WaveShare 3.5" and 4" LCD displays designed for Raspberry Pi. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/input.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index e410fe8d0c..76b4f40bdd 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -173,6 +173,25 @@ endef
$(eval $(call KernelPackage,input-matrixkmap))
+define KernelPackage/input-touchscreen-ads7846
+ SUBMENU:=$(INPUT_MODULES_MENU)
+ TITLE:=ADS7846/TSC2046/AD7873 and AD(S)7843 based touchscreens
+ DEPENDS:=+kmod-hwmon-core +kmod-spi-bitbang
+ KCONFIG:= \
+ CONFIG_INPUT_TOUCHSCREEN=y \
+ CONFIG_TOUCHSCREEN_PROPERTIES=y \
+ CONFIG_TOUCHSCREEN_ADS7846
+ FILES:=$(LINUX_DIR)/drivers/input/touchscreen/ads7846.ko
+ AUTOLOAD:=$(call AutoProbe,ads7846)
+endef
+
+define KernelPackage/input-touchscreen-ads7846/description
+ Kernel module for ADS7846/TSC2046/AD7873 and AD(S)7843 based touchscreens
+endef
+
+$(eval $(call KernelPackage,input-touchscreen-ads7846))
+
+
define KernelPackage/keyboard-imx
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=IMX keypad support