summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorAlberto Bursi <alberto.bursi@outlook.it>2019-09-16 00:54:20 +0200
committerPetr Štetiar <ynezz@true.cz>2019-09-21 08:41:49 +0200
commite9c16e4e1f0c43c46549d8ab1a963613667f46df (patch)
tree30d91ae286c65483c3cbf14645e8416797e01d12 /package/kernel/linux
parentcd96cdaa6038349aee7b26e906e222a14435a076 (diff)
downloadopenwrt-e9c16e4e1f0c43c46549d8ab1a963613667f46df.tar.gz
openwrt-e9c16e4e1f0c43c46549d8ab1a963613667f46df.tar.bz2
openwrt-e9c16e4e1f0c43c46549d8ab1a963613667f46df.zip
kernel: add module for Emulex OneConnect 10Gbit
add module to support Emulex OneConnect common in 10Gbit SFP+ cards by Dell/HP/IBM supports OneConnect OCe10xxx OCe11xxx OCe14xxx, LightPulse LPe12xxx Signed-off-by: Alberto Bursi <alberto.bursi@outlook.it> (cherry picked from commit 827f47749b75dcc6b650297b9303c27127b15201)
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/netdevices.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index e77ddfd5f0..6ea2f1df89 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -991,3 +991,25 @@ define KernelPackage/bnx2/description
endef
$(eval $(call KernelPackage,bnx2))
+
+
+define KernelPackage/be2net
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Broadcom Emulex OneConnect 10Gbps NIC
+ DEPENDS:=@PCI_SUPPORT +kmod-hwmon-core
+ FILES:=$(LINUX_DIR)/drivers/net/ethernet/emulex/benet/be2net.ko
+ KCONFIG:= \
+ CONFIG_BE2NET \
+ CONFIG_BE2NET_BE2=y \
+ CONFIG_BE2NET_BE3=y \
+ CONFIG_BE2NET_LANCER=y \
+ CONFIG_BE2NET_SKYHAWK=y \
+ CONFIG_BE2NET_HWMON=y
+ AUTOLOAD:=$(call AutoProbe,be2net)
+endef
+
+define KernelPackage/be2net/description
+ Broadcom Emulex OneConnect 10Gbit SFP+ support, OneConnect OCe10xxx OCe11xxx OCe14xxx, LightPulse LPe12xxx
+endef
+
+$(eval $(call KernelPackage,be2net))