summaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2018-06-11 00:22:36 +0200
committerJo-Philipp Wich <jo@mein.io>2018-12-18 17:22:08 +0100
commitec9e3e6a9e3e909139bef974f4310c4debe6a4c6 (patch)
treeca0762e78d3c3350e71c0d335edf5041f603456a /package/libs
parent492174198f612df46c58b2dcd636cad163a13ca8 (diff)
downloadopenwrt-ec9e3e6a9e3e909139bef974f4310c4debe6a4c6.tar.gz
openwrt-ec9e3e6a9e3e909139bef974f4310c4debe6a4c6.tar.bz2
openwrt-ec9e3e6a9e3e909139bef974f4310c4debe6a4c6.zip
mbedtls: Cosmetic cleanups
This is more of a cosmetic change and a reminder that the CMake script hardcodes -O2. Source: https://github.com/ARMmbed/mbedtls/blob/mbedtls-2.7/CMakeLists.txt#L73 https://github.com/ARMmbed/mbedtls/blob/master/CMakeLists.txt#L97 Remove the release type option as it's already provided by the toolchain. Source: https://github.com/openwrt/openwrt/blob/master/include/cmake.mk#L50 Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net> (backported from 5297a759aee34952299d1d42f677f31781026c67)
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/mbedtls/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/mbedtls/Makefile b/package/libs/mbedtls/Makefile
index 4556ad80b4..659bf59d88 100644
--- a/package/libs/mbedtls/Makefile
+++ b/package/libs/mbedtls/Makefile
@@ -64,9 +64,9 @@ endef
PKG_INSTALL:=1
TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_CFLAGS := $(filter-out -O%,$(TARGET_CFLAGS))
CMAKE_OPTIONS += \
- -DCMAKE_BUILD_TYPE:String="Release" \
-DUSE_SHARED_MBEDTLS_LIBRARY:Bool=ON \
-DENABLE_TESTING:Bool=OFF \
-DENABLE_PROGRAMS:Bool=ON