summaryrefslogtreecommitdiffstats
path: root/package/network/config/netifd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2024-04-12 21:51:50 +0200
committerFelix Fietkau <nbd@nbd.name>2024-04-14 16:24:37 +0200
commita205a5734eda4604a19b6cb0f65909ef69730699 (patch)
tree39446d51255e400e299fb1d6f45932fb4db0bba6 /package/network/config/netifd/Makefile
parentc2f52e42b1e9f736edd6e4545ebe3435db6605ee (diff)
downloadopenwrt-a205a5734eda4604a19b6cb0f65909ef69730699.tar.gz
openwrt-a205a5734eda4604a19b6cb0f65909ef69730699.tar.bz2
openwrt-a205a5734eda4604a19b6cb0f65909ef69730699.zip
netifd: rewrite packet steering script
The new script uses a different strategy compared to the previous one. Instead of trying to split flows by hash and spread them to all CPUs, use RPS to redirect packets to a single core only. Try to spread NAPI thread and RPS target CPUs across available CPUs and try to ensure that the NAPI thread is on a different CPU than the RPS target. This significantly reduces cycles wasted on the scheduler. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network/config/netifd/Makefile')
-rw-r--r--package/network/config/netifd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index 35b5c0b277..d80c2eeed6 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/cmake.mk
define Package/netifd
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+libuci +libnl-tiny +libubus +ubus +ubusd +jshn +libubox +libudebug
+ DEPENDS:=+libuci +libnl-tiny +libubus +ubus +ubusd +jshn +libubox +libudebug +ucode +ucode-mod-fs
TITLE:=OpenWrt Network Interface Configuration Daemon
endef