summaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-05-17 23:19:52 +0300
committerPaul Spooren <mail@aparcar.org>2024-05-17 23:21:26 +0300
commitb773ca1a966de99a43925bbaa2ac775536a7b112 (patch)
tree91384ba73dcf5cad64b640453e123ee5868f7f26 /package/system
parentbcc641504d401336336ae1ada8a9935ff05c6055 (diff)
downloadopenwrt-b773ca1a966de99a43925bbaa2ac775536a7b112.tar.gz
openwrt-b773ca1a966de99a43925bbaa2ac775536a7b112.tar.bz2
openwrt-b773ca1a966de99a43925bbaa2ac775536a7b112.zip
apk: disable helptext for host build
The host build would need Lua to compile which currently adds a race condition. Instead of tracking that down just disable helptext for the host build. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package/system')
-rw-r--r--package/system/apk/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/system/apk/Makefile b/package/system/apk/Makefile
index 0f0e043986..7aaf9f4c5e 100644
--- a/package/system/apk/Makefile
+++ b/package/system/apk/Makefile
@@ -17,8 +17,7 @@ PKG_LICENSE_FILES:=LICENSE
PKG_INSTALL:=1
HOST_BUILD_PREFIX:=$(STAGING_DIR_HOST)
-HOST_BUILD_DEPENDS:=lua/host
-PKG_BUILD_DEPENDS:=$(HOST_BUILD_DEPENDS)
+PKG_BUILD_DEPENDS:=lua/host
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
@@ -53,7 +52,7 @@ MESON_HOST_VARS+=VERSION=$(PKG_VERSION)
MESON_VARS+=VERSION=$(PKG_VERSION)
MESON_HOST_ARGS += \
- -Dlua_version=5.1 \
+ -Dhelp=disabled \
-Dcompressed-help=false \
-Ddocs=disabled \
-Dcrypto_backend=openssl \