summaryrefslogtreecommitdiffstats
path: root/package/utils/mdadm
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-05-31 14:39:12 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-06-05 12:24:01 -0700
commit5229c453630c0b023c3d65ef6005adbe48062bbb (patch)
tree59f6ff26f92c83931edd42e3542657a7f3c14281 /package/utils/mdadm
parent334f8f4fc33f5fbc52e08477f00971f1e66405ae (diff)
downloadopenwrt-5229c453630c0b023c3d65ef6005adbe48062bbb.tar.gz
openwrt-5229c453630c0b023c3d65ef6005adbe48062bbb.tar.bz2
openwrt-5229c453630c0b023c3d65ef6005adbe48062bbb.zip
mdadm: Do not check RUN_DIR
Fixes build failure on hosts that do not have mdadm installed/configured: make[3]: Entering directory `/local/users/fainelli/openwrt/trunk/build_dir/target-mipsel-linux-gnu_glibc/mdadm-4.0' ***** Parent of /run/mdadm does not exist. Maybe set different RUN_DIR= ***** e.g. make RUN_DIR=/dev/.mdadm ***** or set CHECK_RUN_DIR=0 make[3]: *** [check_rundir] Error 1 make[3]: Leaving directory `/local/users/fainelli/openwrt/trunk/build_dir/target-mipsel-linux-gnu_glibc/mdadm-4.0' make[2]: *** [/local/users/fainelli/openwrt/trunk/build_dir/target-mipsel-linux-gnu_glibc/mdadm-4.0/.built] Error 2 make[2]: Leaving directory `/local/users/fainelli/openwrt/trunk/package/utils/mdadm' make[1]: *** [package/utils/mdadm/compile] Error 2 make[1]: Leaving directory `/local/users/fainelli/openwrt/trunk' make: *** [package/mdadm/compile] Error 2 Fixes: 980c41f8e04f ("utils/mdadm: Update to 4.0") Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package/utils/mdadm')
-rw-r--r--package/utils/mdadm/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/utils/mdadm/Makefile b/package/utils/mdadm/Makefile
index c25f34e511..1ed62d8174 100644
--- a/package/utils/mdadm/Makefile
+++ b/package/utils/mdadm/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mdadm
PKG_VERSION:=4.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=@KERNEL/linux/utils/raid/mdadm
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -50,6 +50,7 @@ define Build/Compile
CC="$(TARGET_CC)" \
CFLAGS="$(TARGET_CFLAGS) -DHAVE_STDINT_H" \
LDFLAGS="$(TARGET_LDFLAGS)" \
+ CHECK_RUN_DIR=0 \
mdadm
endef