summaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2024-05-09 00:16:11 +0200
committerJo-Philipp Wich <jo@mein.io>2024-05-09 00:56:56 +0200
commit51c70e459d0e5bd8e1c9df63b5fd3c0025e831d3 (patch)
tree49e19f8adb38c0419343e5ada79d328c25cc11e8 /package/utils
parent4e53a3f47ed1312e87b032a839e98813d9605aad (diff)
downloadopenwrt-51c70e459d0e5bd8e1c9df63b5fd3c0025e831d3.tar.gz
openwrt-51c70e459d0e5bd8e1c9df63b5fd3c0025e831d3.tar.bz2
openwrt-51c70e459d0e5bd8e1c9df63b5fd3c0025e831d3.zip
ucode: update to Git HEAD (2024-05-09)
cfe137be068a uci: remove incorrectly documentated reorder() parameter e8d78a26da0c lib: introduce socket library a0ad1d127ae6 build: fix symbol and library detection 674f65ee551d jsdoc: disable default module titles a33d16a86493 socket: rework error handling e2b81d869222 uloop: add documentation 953f36c96e8a socket: make socket.send() accept non-string data f211d5ac666f ubus: fix uc_ubus_have_uloop for eloop+uloop combination 0662de64bd1f socket: add AF_PACKET socket type support b594ff8a2841 socket: remove leftover debug code 0d823e702bfe socket: fix addrinfo() with omitted service argument Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/ucode/Makefile10
-rw-r--r--package/utils/ucode/patches/100-ubus-fix-uc_ubus_have_uloop-for-eloop-uloop-combinat.patch26
2 files changed, 7 insertions, 29 deletions
diff --git a/package/utils/ucode/Makefile b/package/utils/ucode/Makefile
index f9db6b060e..ac23161c5e 100644
--- a/package/utils/ucode/Makefile
+++ b/package/utils/ucode/Makefile
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=https://github.com/jow-/ucode.git
-PKG_SOURCE_DATE:=2024-04-07
-PKG_SOURCE_VERSION:=5507654a498a339c44b642f62e203e1d5fb1f725
-PKG_MIRROR_HASH:=40d3df5308faaf3cddfca4ebbcd9ee7fff98cf7e7d406dc177972a7abf0ca16b
+PKG_SOURCE_DATE:=2024-05-09
+PKG_SOURCE_VERSION:=0d823e702bfe5f2bb5be694030a98afedf34aa6b
+PKG_MIRROR_HASH:=c52d499d2490e958e36ed80c32e8fd6d94cacf3b43b9d14c45c68a25bc44d536
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=ISC
@@ -156,6 +156,10 @@ $(eval $(call UcodeModule, \
The rtnl plugin provides access to the Linux routing netlink API.))
$(eval $(call UcodeModule, \
+ socket, SOCKET_SUPPORT, , \
+ The socket plugin provides access to IPv4, IPv6, Unix and packet socket APIs.))
+
+$(eval $(call UcodeModule, \
struct, STRUCT_SUPPORT, , \
The struct plugin implements Python 3 compatible struct.pack/unpack functionality.))
diff --git a/package/utils/ucode/patches/100-ubus-fix-uc_ubus_have_uloop-for-eloop-uloop-combinat.patch b/package/utils/ucode/patches/100-ubus-fix-uc_ubus_have_uloop-for-eloop-uloop-combinat.patch
deleted file mode 100644
index a1659be3c8..0000000000
--- a/package/utils/ucode/patches/100-ubus-fix-uc_ubus_have_uloop-for-eloop-uloop-combinat.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From: Felix Fietkau <nbd@nbd.name>
-Date: Wed, 1 May 2024 18:40:19 +0200
-Subject: [PATCH] ubus: fix uc_ubus_have_uloop for eloop+uloop combination
-
-When uloop has been integrated with eloop (in hostapd/wpa_supplicant),
-uloop_cancelling will return false, since uloop_run is not being called.
-This leads to ubus.defer() calling uloop_run in a context where it can
-prevent the other event loop from running.
-
-Fix this by detecting event loop integration via uloop_fd_set_cb being set
-
-Signed-off-by: Felix Fietkau <nbd@nbd.name>
----
-
---- a/lib/ubus.c
-+++ b/lib/ubus.c
-@@ -665,6 +665,9 @@ uc_ubus_have_uloop(void)
- bool prev = uloop_cancelled;
- bool active;
-
-+ if (uloop_fd_set_cb)
-+ return true;
-+
- uloop_cancelled = true;
- active = uloop_cancelling();
- uloop_cancelled = prev;