summaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-12-10 18:04:53 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-12-28 12:26:23 +0100
commit20c349f68ca108d8b20363efbf5fa698e8446009 (patch)
tree0ec8dfb0cb2b0297cc500ebd0fd44fcd3cf6e12c /package/utils
parenta10fae113349f120486c86fc616948b5b6f1a76e (diff)
downloadopenwrt-20c349f68ca108d8b20363efbf5fa698e8446009.tar.gz
openwrt-20c349f68ca108d8b20363efbf5fa698e8446009.tar.bz2
openwrt-20c349f68ca108d8b20363efbf5fa698e8446009.zip
busybox: add missing TARGET_CPPFLAGS and TARGET_LDFLAGS
Unconditionally pass TARGET_CPPFLAGS (not passed at all before) and TARGET_LDFLAGS (passed only in certain non-default configuration before the Makefile streamlining). Without these flags, hardening options (PKG_FORTIFY_SOURCE and PKG_RELRO) were not actually applied to busybox. The addition of these flags increases the size of the stripped busybox binary by about 6KB (~4KB with fortify headers, ~2KB with "-znow -zrelro") with the default hardening options PKG_FORTIFY_SOURCE_1 and PKG_RELRO_FULL. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/busybox/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 54ad986e66..8866756aea 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.27.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -83,7 +83,8 @@ endif
MAKE_VARS :=
MAKE_FLAGS += \
- EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+ EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+ EXTRA_LDFLAGS="$(TARGET_LDFLAGS)" \
LDLIBS="$(LDLIBS)" \
SKIP_STRIP=y
ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)