summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2023-11-20 19:16:45 +0100
committerFelix Fietkau <nbd@nbd.name>2023-11-20 19:18:06 +0100
commitcafb96185031f21412a10ef8f9125fa6da5fa731 (patch)
tree34fc4d49b52655ab6420f7835b6a35787af1f22f /package
parent2634d3f855ee3ca97a311512c0717cf84a8e274a (diff)
downloadopenwrt-cafb96185031f21412a10ef8f9125fa6da5fa731.tar.gz
openwrt-cafb96185031f21412a10ef8f9125fa6da5fa731.tar.bz2
openwrt-cafb96185031f21412a10ef8f9125fa6da5fa731.zip
netifd: update to Git HEAD (2023-11-20), adds udebug support
9dcc37a77cb2 add udebug support 525fa911e8ab replace DPRINTF calls with D(...) 7642eaba3838 system-linux: fix bogus debug error messages on adding bridge members f3e06e81b347 wireless: add bridge_isolate option Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package')
-rw-r--r--package/libs/udebug/files/udebug.config4
-rw-r--r--package/network/config/netifd/Makefile8
2 files changed, 8 insertions, 4 deletions
diff --git a/package/libs/udebug/files/udebug.config b/package/libs/udebug/files/udebug.config
index c240553c8a..36b653e306 100644
--- a/package/libs/udebug/files/udebug.config
+++ b/package/libs/udebug/files/udebug.config
@@ -1,4 +1,8 @@
config service hostapd
option enabled 0
+
config service wpa_supplicant
option enabled 0
+
+config service netifd
+ option enabled 0
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index 2e70994e51..ccd566e0a7 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -5,9 +5,9 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
-PKG_SOURCE_DATE:=2023-11-14
-PKG_SOURCE_VERSION:=8587c074f1eb2064c42adb0a6aa5073f695ab89d
-PKG_MIRROR_HASH:=f5ceb771badd7a23cceb53537299580d4b483e2b3ec5de09b9c3c54692893dd9
+PKG_SOURCE_DATE:=2023-11-20
+PKG_SOURCE_VERSION:=f3e06e81b347bbdec1c6c71603328b6e442728d4
+PKG_MIRROR_HASH:=f16dd61aede5597fd7b5ee8e7752a916494281bc981b35c16e788ddb7409584a
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=GPL-2.0
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/cmake.mk
define Package/netifd
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+libuci +libnl-tiny +libubus +ubus +ubusd +jshn +libubox
+ DEPENDS:=+libuci +libnl-tiny +libubus +ubus +ubusd +jshn +libubox +libudebug
TITLE:=OpenWrt Network Interface Configuration Daemon
endef