summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-12-24 00:46:51 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-12-24 01:04:14 +0100
commit36057763fa99dc1091600bdfb5f3683fa044dac2 (patch)
treec1e2f18008d7e884b1831acb5f4012af4a123896 /package
parent450b306e540bc0f2c8a8841bbe4d9612f2b8cdea (diff)
downloadopenwrt-36057763fa99dc1091600bdfb5f3683fa044dac2.tar.gz
openwrt-36057763fa99dc1091600bdfb5f3683fa044dac2.tar.bz2
openwrt-36057763fa99dc1091600bdfb5f3683fa044dac2.zip
ath10k-firmware: Add kmod-ath10k-ct-smallbuffers to depends
Only select ath10k-ct-regular when smallbuffers version was not selected. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit 80f06cb601160534f20e61d476dcedba77d5a47d)
Diffstat (limited to 'package')
-rw-r--r--package/firmware/ath10k-firmware/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index a57fcb59ba..5a6c18a4e8 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -174,7 +174,7 @@ $(Package/ath10k-firmware-default)
SECTION:=firmware
CATEGORY:=Firmware
PROVIDES:=ath10k-firmware-qca988x
- DEPENDS:=+kmod-ath10k-ct
+ DEPENDS:=+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
endef
define Package/ath10k-firmware-qca9887-ct
@@ -190,7 +190,7 @@ $(Package/ath10k-firmware-default)
SECTION:=firmware
CATEGORY:=Firmware
PROVIDES:=ath10k-firmware-qca9887
- DEPENDS:=+kmod-ath10k-ct
+ DEPENDS:=+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
endef
define Package/ath10k-firmware-qca988x-ct/description
@@ -308,7 +308,7 @@ $(Package/ath10k-firmware-default)
SECTION:=firmware
CATEGORY:=Firmware
PROVIDES:=ath10k-firmware-qca99x0
- DEPENDS:=+kmod-ath10k-ct
+ DEPENDS:=+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
endef
define Package/ath10k-firmware-qca9984-ct
@@ -324,7 +324,7 @@ $(Package/ath10k-firmware-default)
SECTION:=firmware
CATEGORY:=Firmware
PROVIDES:=ath10k-firmware-qca9984
- DEPENDS:=+kmod-ath10k-ct
+ DEPENDS:=+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
endef
define Package/ath10k-firmware-qca4019-ct
@@ -340,7 +340,7 @@ $(Package/ath10k-firmware-default)
SECTION:=firmware
CATEGORY:=Firmware
PROVIDES:=ath10k-firmware-qca4019
- DEPENDS:=+kmod-ath10k-ct
+ DEPENDS:=+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
endef
define Package/ath10k-firmware-qca9888-ct
@@ -356,7 +356,7 @@ $(Package/ath10k-firmware-default)
SECTION:=firmware
CATEGORY:=Firmware
PROVIDES:=ath10k-firmware-qca9888
- DEPENDS:=+kmod-ath10k-ct
+ DEPENDS:=+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
endef