summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorleo chung <gewalalb@gmail.com>2019-09-20 13:33:58 +0800
committerPetr Štetiar <ynezz@true.cz>2019-10-09 21:07:23 +0200
commit53a6aa5164713c74570c4fbd28d56a75137dd00d (patch)
treeda92dc3dcb058cbb884442bb064ea4df3b59becd /scripts
parentf2c321fc078e5e210aac97216f26c8c97cd7b93d (diff)
downloadopenwrt-53a6aa5164713c74570c4fbd28d56a75137dd00d.tar.gz
openwrt-53a6aa5164713c74570c4fbd28d56a75137dd00d.tar.bz2
openwrt-53a6aa5164713c74570c4fbd28d56a75137dd00d.zip
build: fix xconfig target
`make xconfig` fails with following linking error of qconf binary: g++ -lQt5Widgets -lQt5Gui -lQt5Core -o qconf qconf.o zconf.tab.o /usr/bin/ld: qconf.o: in function ConfigList::metaObject() const': qconf.cc:(.text+0x3eb): undefined reference to QObjectData::dynamicMetaObject() const' /usr/bin/ld: qconf.o: in function `ConfigList::qt_metacast(char const*)': link error. which is caused by the wrong order of the linked objects/libraries so this patch reorders the linker's arguments which makes the qconf compile again. Signed-off-by: leo chung <gewalalb@gmail.com> [commit subject and message tweaks, whitespace fix] Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit b2c55d50f8aeb21ef4cd3948034a158f7dd743c2)
Diffstat (limited to 'scripts')
-rw-r--r--scripts/config/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/config/Makefile b/scripts/config/Makefile
index 8b78d5a682..0eac8edd22 100644
--- a/scripts/config/Makefile
+++ b/scripts/config/Makefile
@@ -40,7 +40,7 @@ mconf: $(mconf-objs) $(lxdialog-objs)
$(CC) -o $@ $^ $(call check_lxdialog,ldflags $(CC))
qconf: $(qconf-cxxobjs) $(qconf-objs)
ifneq ($(DISTRO-PKG-CONFIG),)
- $(CXX) $(HOSTLOADLIBES_qconf) -o $@ $^
+ $(CXX) -o $@ $^ $(HOSTLOADLIBES_qconf)
else
echo "You don't have 'pkg-config' installed. Cannot continue"
echo "For now, you may use 'make menuconfig' instead of 'make xconfig'"