summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-04-08 10:17:01 -1000
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-30 22:13:05 +0200
commit938839a56586c13defe3e824c2445310ca50c7dc (patch)
treed1f4d5e30b397f1f8f2571008a72b518aa822fb2 /scripts
parent3572711e3cea24dd5276666860f57a2c3a72525e (diff)
downloadopenwrt-938839a56586c13defe3e824c2445310ca50c7dc.tar.gz
openwrt-938839a56586c13defe3e824c2445310ca50c7dc.tar.bz2
openwrt-938839a56586c13defe3e824c2445310ca50c7dc.zip
scripts: JSON merge don't crash if no JSON found
The JSON `WORK_DIR` ($(KDIR)/json_info_files) is only created if the new image generation methods from `image.mk` are used. However some targets like `armvirt` do not use it yet, so the folder is never created. The `json_overview_image_info.py` script used to raise an error if the given `WORK_DIR` isn't a folder, however it should just notify about missing JSON files. This patch removes the Python assert and exists with code 0 even if no JSON files were found, as this is not necessarily an error but simply not yet implemented. Using `glob` on an not existing `Path` results in an empty list, therefore the for loop won't run. Signed-off-by: Paul Spooren <mail@aparcar.org> CC: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 14cbd8fb2dd8c81bad06d3c3bb45213685c19c98)
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/json_overview_image_info.py2
1 files changed, 0 insertions, 2 deletions
diff --git a/scripts/json_overview_image_info.py b/scripts/json_overview_image_info.py
index 5ed829249b..a1418e366d 100755
--- a/scripts/json_overview_image_info.py
+++ b/scripts/json_overview_image_info.py
@@ -15,8 +15,6 @@ assert getenv("WORK_DIR"), "$WORK_DIR required"
work_dir = Path(getenv("WORK_DIR"))
-assert work_dir.is_dir(), "$WORK_DIR not a directory"
-
output = {}
for json_file in work_dir.glob("*.json"):