summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2024-01-30 21:28:54 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2024-03-04 16:27:39 +0100
commitfb80be694427e9d692c02c6ab7b10caf4e539a62 (patch)
tree1fd03bde8c14857a388346cfd6f6e3ed4c360bd4 /target/linux/bcm27xx
parent552c6b24724d81a9651a0e64a01135c18c6487ea (diff)
downloadopenwrt-fb80be694427e9d692c02c6ab7b10caf4e539a62.tar.gz
openwrt-fb80be694427e9d692c02c6ab7b10caf4e539a62.tar.bz2
openwrt-fb80be694427e9d692c02c6ab7b10caf4e539a62.zip
bcm27xx: pass signature to partition generation
Passes IMG_PART_SIGNATURE to ptgen instead of using the default "OWRT" signature. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm27xx')
-rw-r--r--target/linux/bcm27xx/image/Makefile1
-rwxr-xr-xtarget/linux/bcm27xx/image/gen_rpi_sdcard_img.sh2
2 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/bcm27xx/image/Makefile b/target/linux/bcm27xx/image/Makefile
index 12ac0012a4..e45f53de8e 100644
--- a/target/linux/bcm27xx/image/Makefile
+++ b/target/linux/bcm27xx/image/Makefile
@@ -49,6 +49,7 @@ define Build/boot-2711
endef
define Build/sdcard-img
+ SIGNATURE="$(IMG_PART_SIGNATURE)" \
./gen_rpi_sdcard_img.sh $@ $@.boot $(IMAGE_ROOTFS) \
$(CONFIG_TARGET_KERNEL_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
endef
diff --git a/target/linux/bcm27xx/image/gen_rpi_sdcard_img.sh b/target/linux/bcm27xx/image/gen_rpi_sdcard_img.sh
index 488a3517c7..8d33e4f54c 100755
--- a/target/linux/bcm27xx/image/gen_rpi_sdcard_img.sh
+++ b/target/linux/bcm27xx/image/gen_rpi_sdcard_img.sh
@@ -19,7 +19,7 @@ kernel_type=c
rootfs_type=83
sect=63
-set $(ptgen -o $OUTPUT -h $head -s $sect -l $align -t $kernel_type -p ${BOOTFSSIZE}M -t $rootfs_type -p ${ROOTFSSIZE}M)
+set $(ptgen -o $OUTPUT -h $head -s $sect -l $align -t $kernel_type -p ${BOOTFSSIZE}M -t $rootfs_type -p ${ROOTFSSIZE}M ${SIGNATURE:+-S 0x$SIGNATURE})
BOOTOFFSET="$(($1 / 512))"
ROOTFSOFFSET="$(($3 / 512))"