summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/hack-4.9/220-gc_sections.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-12-16 21:09:41 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-12-19 22:45:27 +0100
commitf704b643b9cab8fa6d3eb7c33a7fbd117ecd821a (patch)
tree4ba50f0c0cea60c564d9b76b49ac2985386c4d56 /target/linux/generic/hack-4.9/220-gc_sections.patch
parente80ab48777d83d8c24fcd397a85649f08b6b5f87 (diff)
downloadopenwrt-f704b643b9cab8fa6d3eb7c33a7fbd117ecd821a.tar.gz
openwrt-f704b643b9cab8fa6d3eb7c33a7fbd117ecd821a.tar.bz2
openwrt-f704b643b9cab8fa6d3eb7c33a7fbd117ecd821a.zip
kernel: Update kernel 4.9 to 4.9.70
Runtime tested on lantiq. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/generic/hack-4.9/220-gc_sections.patch')
-rw-r--r--target/linux/generic/hack-4.9/220-gc_sections.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/generic/hack-4.9/220-gc_sections.patch b/target/linux/generic/hack-4.9/220-gc_sections.patch
index eda8bb8b2b..e39f0f5f44 100644
--- a/target/linux/generic/hack-4.9/220-gc_sections.patch
+++ b/target/linux/generic/hack-4.9/220-gc_sections.patch
@@ -21,9 +21,9 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
--- a/Makefile
+++ b/Makefile
-@@ -409,6 +409,11 @@ KBUILD_AFLAGS_MODULE := -DMODULE
- KBUILD_CFLAGS_MODULE := -DMODULE
+@@ -404,6 +404,11 @@ KBUILD_CFLAGS_MODULE := -DMODULE
KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
+ GCC_PLUGINS_CFLAGS :=
+ifdef CONFIG_LD_DEAD_CODE_DATA_ELIMINATION
+KBUILD_CFLAGS_KERNEL += $(call cc-option,-ffunction-sections,)
@@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
-@@ -633,11 +638,6 @@ KBUILD_CFLAGS += $(call cc-disable-warni
+@@ -634,11 +639,6 @@ KBUILD_CFLAGS += $(call cc-disable-warni
KBUILD_CFLAGS += $(call cc-disable-warning, format-overflow)
KBUILD_CFLAGS += $(call cc-disable-warning, int-in-bool-context)