summaryrefslogtreecommitdiffstats
path: root/target/linux/qualcommax/image/ipq807x.mk
diff options
context:
space:
mode:
authorChukun Pan <amadeus@jmu.edu.cn>2024-03-26 23:16:05 +0800
committerRobert Marko <robimarko@gmail.com>2024-04-17 12:08:56 +0200
commit9cef2bc224b9bda19a8a79df6d1de9560c081ce2 (patch)
treee6892f8488c5fa9b1ce420ac8b6e6ebda12c9451 /target/linux/qualcommax/image/ipq807x.mk
parent74eb7188714bdafa5a7b56ffb48ad8474e107449 (diff)
downloadopenwrt-9cef2bc224b9bda19a8a79df6d1de9560c081ce2.tar.gz
openwrt-9cef2bc224b9bda19a8a79df6d1de9560c081ce2.tar.bz2
openwrt-9cef2bc224b9bda19a8a79df6d1de9560c081ce2.zip
ipq807x: add support for Zbtlink ZBT-Z800AX
Hardware specifications: SoC: Qualcomm IPQ8072A RAM: 1GB of DDR4 600MHz Flash1: Winbond W25Q64DW 8MB Flash2: MX30UF2G28AD 256MB WiFi1: QCN5024 2.4GHz AX 4x4 WiFi2: QCN5054 5GHz AX 4x4 Ethernet: 5x 1G RJ45 port USB: 2x USB 3.0 (1x M.2) Button: Reset, WPS Flash instructions: Upload factory.bin in stock firmware's upgrade page, do not preserve settings. Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
Diffstat (limited to 'target/linux/qualcommax/image/ipq807x.mk')
-rw-r--r--target/linux/qualcommax/image/ipq807x.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/qualcommax/image/ipq807x.mk b/target/linux/qualcommax/image/ipq807x.mk
index 74fe15a997..027278b63c 100644
--- a/target/linux/qualcommax/image/ipq807x.mk
+++ b/target/linux/qualcommax/image/ipq807x.mk
@@ -299,6 +299,21 @@ define Device/yuncore_ax880
endef
TARGET_DEVICES += yuncore_ax880
+define Device/zbtlink_zbt-z800ax
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_VENDOR := Zbtlink
+ DEVICE_MODEL := ZBT-Z800AX
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ DEVICE_DTS_CONFIG := config@hk09
+ SOC := ipq8072
+ DEVICE_PACKAGES := ipq-wifi-zbtlink_zbt-z800ax
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-ubi | qsdk-ipq-factory-nand
+endef
+TARGET_DEVICES += zbtlink_zbt-z800ax
+
define Device/zte_mf269
$(call Device/FitImage)
$(call Device/UbiFit)