summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorVince McKinsey <vincemckinsey@gmail.com>2024-03-31 14:29:05 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2024-04-14 20:34:36 +0200
commitcab2e1de0d94ab35b5d032194fc5b4ab2e0d609a (patch)
tree4c9a1d512a1a12f5b59189821d799b15cb93ea41 /target/linux/ramips/image/mt7621.mk
parent338b463e1e9788f9e569cfa26b76a2a9746c93c1 (diff)
downloadopenwrt-cab2e1de0d94ab35b5d032194fc5b4ab2e0d609a.tar.gz
openwrt-cab2e1de0d94ab35b5d032194fc5b4ab2e0d609a.tar.bz2
openwrt-cab2e1de0d94ab35b5d032194fc5b4ab2e0d609a.zip
ramips: Add support for D-Link DIR-3040 A1
This adds support for the A1 hardware revision of the DIR-3040. It is an exact copy of the DIR-3060 save for some cosmetic changes to the housing. Even going so far as having the same FCC ID. Hardware specification: SoC: MediaTek MT7621AT Flash: Winbond W29N01HVSINA 128MB RAM: Micron MT41K128M16JT-125 256MB Ethernet: 5x 10/100/1000 Mbps WiFi1: MT7615DN 2.4GHz N 2x2:2 WiFi2: MT7615DN 5GHz AC 2x2:2 WiFi3: MT7615N 5GHz AC 4x4:4 Button: WPS, Reset Flash instructions: OpenWrt can be installed via D-Link Recovery GUI: NOTE: Seems to only work in Firefox on Windows. Tried with Chrome on Windows, Firefox in Linux, and Chromium in Linux. None of these other browsers worked. 1. Push and hold reset button (on the bottom of the device) until power led starts flashing (about 10 secs or so) while plugging in the power cable. 2. Give it ~30 seconds, to boot the recovery mode GUI 3. Connect your client computer to LAN1 of the device 4. Set your client IP address manually to 192.168.0.2 / 255.255.255.0. 5. Call the recovery page for the device at http://192.168.0.1/ 6. Use the provided emergency web GUI to upload and flash a new firmware to the device Thanks to @Lucky1openwrt and @iivailo for creating the DIR-3060 DTS file and related changes, so it was possible for me to adapt them to the DIR-3040, build images, test and fix minor issues. MAC Addresses: | use | address | example | | --- | --- | --- | | LAN | label | f4:*:61 | | WAN | label + 4 | f4:*:65 | | WI1/2g | label + 2 | f4:*:63 | | WI1/5g | label + 1 | f4:*:62 | | WI2/5g | label + 3 | f4:*:64 | The label MAC address was found in Factory, 0xe000 Checklist: ✓ nand ✓ ethernet ✓ button ✓ wifi2g ✓ wifi5g ✓ wifi5g ✓ mac ✓ led Signed-off-by: Vince McKinsey <vincemckinsey@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index fb8cfce589..10e7857614 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -783,6 +783,13 @@ define Device/dlink_dir-2660-a1
endef
TARGET_DEVICES += dlink_dir-2660-a1
+define Device/dlink_dir-3040-a1
+ $(Device/dlink_dir-xx60-a1)
+ DEVICE_MODEL := DIR-3040
+ DEVICE_VARIANT := A1
+endef
+TARGET_DEVICES += dlink_dir-3040-a1
+
define Device/dlink_dir-3060-a1
$(Device/dlink_dir-xx60-a1)
DEVICE_MODEL := DIR-3060