summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2024-03-27 20:38:04 +0900
committerHauke Mehrtens <hauke@hauke-m.de>2024-06-05 21:14:16 +0200
commit47d9dcd01ac57ec72e2da50957c2f3c83d357f69 (patch)
treeebc9f98f573e7415e5fdcbf3e64e2885512380d5 /target
parentfbeff10b5a47cd7ec4ab57a2ef7e6207cb089ca7 (diff)
downloadopenwrt-47d9dcd01ac57ec72e2da50957c2f3c83d357f69.tar.gz
openwrt-47d9dcd01ac57ec72e2da50957c2f3c83d357f69.tar.bz2
openwrt-47d9dcd01ac57ec72e2da50957c2f3c83d357f69.zip
build: move Build/buffalo-trx to image-commands.mk
Move Build/buffalo-trx to image-commands.mk from image/mt7622.mk to use that definition from ramips as well. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/mediatek/image/mt7622.mk21
1 files changed, 0 insertions, 21 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 441e29a1dc..f91720479a 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -8,27 +8,6 @@ define Image/Prepare
echo -ne '\xde\xad\xc0\xde' > $(KDIR)/ubi_mark
endef
-define Build/buffalo-trx
- $(eval magic=$(word 1,$(1)))
- $(eval kern_bin=$(if $(1),$(IMAGE_KERNEL),$@))
- $(eval rtfs_bin=$(word 2,$(1)))
- $(eval apnd_bin=$(word 3,$(1)))
- $(eval kern_size=$(if $(KERNEL_SIZE),$(KERNEL_SIZE),0x400000))
-
- $(if $(rtfs_bin),touch $(rtfs_bin))
- $(STAGING_DIR_HOST)/bin/otrx create $@.new \
- $(if $(magic),-M $(magic),) \
- -f $(kern_bin) \
- $(if $(rtfs_bin),\
- -a 0x20000 \
- -b $$(( $(call exp_units,$(kern_size)) )) \
- -f $(rtfs_bin),) \
- $(if $(apnd_bin),\
- -A $(apnd_bin) \
- -a 0x20000)
- mv $@.new $@
-endef
-
define Build/bl2
cat $(STAGING_DIR_IMAGE)/mt7622-$1-bl2.img >> $@
endef