summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRodrigo Balerdi <lanchon@gmail.com>2024-11-08 17:40:03 -0300
committerRobert Marko <robimarko@gmail.com>2024-11-17 12:24:43 +0100
commitfe481c9c47d97ebde1bc3c959924f4f9227c6c16 (patch)
tree612daeb8408862690e667deb93bb7030e68370ac /target
parent5583d2318966d5d5dcdbdec2e34b8815d3f6419a (diff)
downloadopenwrt-fe481c9c47d97ebde1bc3c959924f4f9227c6c16.tar.gz
openwrt-fe481c9c47d97ebde1bc3c959924f4f9227c6c16.tar.bz2
openwrt-fe481c9c47d97ebde1bc3c959924f4f9227c6c16.zip
ipq807x: prpl haze & qnap 301w: use the standard eMMC sysupgrade code
Note that the old ad-hoc method did not explicitly align backup data to 64 KiB boundaries. Also note that the qnap 301w has a 'rootfs_data' partition in the eMMC that is being ignored by fstools during boot, presumably due to a bug. This is why the partition is also ignored in the sysupgrade code and there is no definition of CI_DATAPART="rootfs_data". Signed-off-by: Rodrigo Balerdi <lanchon@gmail.com> Link: https://github.com/openwrt/openwrt/pull/16505 Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/qualcommax/image/ipq807x.mk4
-rw-r--r--target/linux/qualcommax/ipq807x/base-files/lib/upgrade/platform.sh8
2 files changed, 7 insertions, 5 deletions
diff --git a/target/linux/qualcommax/image/ipq807x.mk b/target/linux/qualcommax/image/ipq807x.mk
index 401f455585..60af865459 100644
--- a/target/linux/qualcommax/image/ipq807x.mk
+++ b/target/linux/qualcommax/image/ipq807x.mk
@@ -308,7 +308,7 @@ define Device/prpl_haze
DEVICE_DTS_CONFIG := config@hk09
SOC := ipq8072
DEVICE_PACKAGES := ath11k-firmware-qcn9074 ipq-wifi-prpl_haze kmod-ath11k-pci \
- mkf2fs f2fsck kmod-fs-f2fs kmod-leds-lp5562
+ kmod-fs-f2fs f2fs-tools kmod-leds-lp5562
endef
TARGET_DEVICES += prpl_haze
@@ -320,7 +320,7 @@ define Device/qnap_301w
DEVICE_DTS_CONFIG := config@hk01
KERNEL_SIZE := 16384k
SOC := ipq8072
- DEVICE_PACKAGES := ipq-wifi-qnap_301w
+ DEVICE_PACKAGES := kmod-fs-f2fs f2fs-tools ipq-wifi-qnap_301w
endef
TARGET_DEVICES += qnap_301w
diff --git a/target/linux/qualcommax/ipq807x/base-files/lib/upgrade/platform.sh b/target/linux/qualcommax/ipq807x/base-files/lib/upgrade/platform.sh
index f822f6291d..00289dcfe6 100644
--- a/target/linux/qualcommax/ipq807x/base-files/lib/upgrade/platform.sh
+++ b/target/linux/qualcommax/ipq807x/base-files/lib/upgrade/platform.sh
@@ -185,9 +185,9 @@ platform_do_upgrade() {
;;
prpl,haze|\
qnap,301w)
- kernelname="0:HLOS"
- rootfsname="rootfs"
- mmc_do_upgrade "$1"
+ CI_KERNPART="0:HLOS"
+ CI_ROOTPART="rootfs"
+ emmc_do_upgrade "$1"
;;
tplink,eap660hd-v1)
tplink_do_upgrade "$1"
@@ -267,6 +267,8 @@ platform_do_upgrade() {
platform_copy_config() {
case "$(board_name)" in
+ prpl,haze|\
+ qnap,301w|\
spectrum,sax1v1k|\
zyxel,nbg7815)
emmc_copy_config