summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-08-01 09:11:17 +0200
committerJo-Philipp Wich <jo@mein.io>2018-08-01 09:14:36 +0200
commit4f3082583a0f08bf8329c2a6e754fbf4e0bea544 (patch)
tree6403906b68e8df80f786c353653229cb3bd1618b /target
parent5f23d0f3db94155ad4b621f68c18de7ad34d598d (diff)
downloadopenwrt-4f3082583a0f08bf8329c2a6e754fbf4e0bea544.tar.gz
openwrt-4f3082583a0f08bf8329c2a6e754fbf4e0bea544.tar.bz2
openwrt-4f3082583a0f08bf8329c2a6e754fbf4e0bea544.zip
sdk: bundle usbip userspace sources
Bundle the usbip utility sources shipped with the Linux kernel tree in order to allow the usbip packages from the package feed to build within the OpenWrt SDK. Signed-off-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit d0e0b7049f88774e67c3d5ad6b573f7070e5f900)
Diffstat (limited to 'target')
-rw-r--r--target/sdk/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index d3822a0df6..499c2809dd 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -84,6 +84,10 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
$(SDK_DIRS) $(KERNEL_FILES) | \
$(TAR) -xf - -C $(SDK_BUILD_DIR)
+ # Copy usbip sources, this is required for the usbip userspace packages to be buildable by the SDK.
+ $(TAR) -cf - -C $(TOPDIR) $(KDIR_BASE)/tools/usb/usbip/ | \
+ $(TAR) -xf - -C $(SDK_BUILD_DIR)
+
(cd $(SDK_BUILD_DIR); find $(STAGING_SUBDIR_HOST)/bin $(STAGING_SUBDIR_HOST)/usr/bin \
$(STAGING_SUBDIR_TOOLCHAIN)/bin $(STAGING_SUBDIR_TOOLCHAIN)/*/bin $(STAGING_SUBDIR_TOOLCHAIN)/libexec \
-type f | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST))