summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-02-06 19:44:36 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-02-11 19:07:43 +0100
commit2e26bdfeca2ffe381eb17fa9765724be7d45e1d8 (patch)
treee93c22aee9026a946512e9a7193945cb6bddd802 /target
parent28483d4ab236446c3b172c6d6b5742742c9c1bd2 (diff)
downloadopenwrt-2e26bdfeca2ffe381eb17fa9765724be7d45e1d8.tar.gz
openwrt-2e26bdfeca2ffe381eb17fa9765724be7d45e1d8.tar.bz2
openwrt-2e26bdfeca2ffe381eb17fa9765724be7d45e1d8.zip
ar71xx: remove bs-partition ro-flag for UniFi AC
This removes the read-only flag from the bs (bootselect) partition on UniFi AC devices. This allows to correct the indicator from which partition the device is booting its kernel from. See also: - https://github.com/freifunk-gluon/gluon/issues/1301 - https://bugs.lede-project.org/index.php?do=details&task_id=662 Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/ubnt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/ubnt.mk b/target/linux/ar71xx/image/ubnt.mk
index 68fe8ad301..65ed708459 100644
--- a/target/linux/ar71xx/image/ubnt.mk
+++ b/target/linux/ar71xx/image/ubnt.mk
@@ -82,7 +82,7 @@ define Device/ubnt-unifiac
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2
DEVICE_PROFILE := UBNT
IMAGE_SIZE := 7744k
- MTDPARTS = spi0.0:384k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),7744k(ubnt-airos)ro,128k(bs)ro,256k(cfg)ro,64k(EEPROM)ro
+ MTDPARTS = spi0.0:384k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),7744k(ubnt-airos)ro,128k(bs),256k(cfg)ro,64k(EEPROM)ro
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef