summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-06-08 21:41:25 +0200
committerMathias Kresin <dev@kresin.me>2018-06-09 13:46:01 +0200
commit433fb7d2c7846983f686512a7a6136ac03695559 (patch)
tree35831ef48ae4dbbdf82ec365980d51067f9945d0 /target
parent48c5d6ab77b94cc0648f2c408f9480dd3885c508 (diff)
downloadopenwrt-433fb7d2c7846983f686512a7a6136ac03695559.tar.gz
openwrt-433fb7d2c7846983f686512a7a6136ac03695559.tar.bz2
openwrt-433fb7d2c7846983f686512a7a6136ac03695559.zip
ar71xx: fix AVM package selection
The AVM package selection partially broke with the addition of the FRITZ!Box 4020. This commit restores the intended behavior. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/generic.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index bceeba0009..a49b0d655d 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -1305,7 +1305,7 @@ endef
define Device/fritz300e
$(call Device/AVM)
DEVICE_TITLE := AVM FRITZ!WLAN Repeater 300E
- DEVICE_PACKAGES := rssileds -swconfig
+ DEVICE_PACKAGES += rssileds -swconfig
BOARDNAME := FRITZ300E
SUPPORTED_DEVICES := fritz300e
IMAGE_SIZE := 15232k
@@ -1315,7 +1315,7 @@ TARGET_DEVICES += fritz300e
define Device/fritz4020
$(call Device/AVM)
DEVICE_TITLE := AVM FRITZ!Box 4020
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage
+ DEVICE_PACKAGES += kmod-usb-core kmod-usb2 kmod-usb-storage
BOARDNAME := FRITZ4020
SUPPORTED_DEVICES := fritz4020
IMAGE_SIZE := 15232k