summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorKimmo Vuorinen <kimmo.vuorinen@gmail.com>2020-01-22 23:38:35 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 14:33:21 +0100
commitb6675c2b2e966f7046a787d4366dd031ce70bf0e (patch)
tree818991e94210e1fda1d06bf1c6debfac5254c0ae /target
parenteed8f30b98bb420aa86eb8375b9ab82c246a08cc (diff)
downloadopenwrt-b6675c2b2e966f7046a787d4366dd031ce70bf0e.tar.gz
openwrt-b6675c2b2e966f7046a787d4366dd031ce70bf0e.tar.bz2
openwrt-b6675c2b2e966f7046a787d4366dd031ce70bf0e.zip
ar71xx: change u-boot-env to read-write for gl-ar150/-domino/mifi
Change u-boot-env partitions to be mounted as read-write for gl-ar150, gl-domino and gl-mifi so uboot-envtools support is possible. Signed-off-by: Kimmo Vuorinen <kimmo.vuorinen@gmail.com> [commit title/message facelift] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit 2c1cfacddedc82c7a34eeb2a26529a5f3ab423d8)
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/generic.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 30a8b34483..3ba27aa659 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -462,7 +462,7 @@ define Device/gl-ar150
BOARDNAME := GL-AR150
IMAGE_SIZE := 16000k
CONSOLE := ttyATH0,115200
- MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
endef
TARGET_DEVICES += gl-ar150
@@ -516,7 +516,7 @@ define Device/gl-domino
BOARDNAME := DOMINO
IMAGE_SIZE := 16000k
CONSOLE := ttyATH0,115200
- MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
endef
TARGET_DEVICES += gl-domino
@@ -526,7 +526,7 @@ define Device/gl-mifi
BOARDNAME := GL-MIFI
IMAGE_SIZE := 16000k
CONSOLE := ttyATH0,115200
- MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
endef
TARGET_DEVICES += gl-mifi