summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-05-04 22:47:27 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 13:02:44 +0200
commit047361dee44cab2b2355f7b7859fd688f6483cbc (patch)
treec025ae837defcf9cd9afd3d11a1b2930ac5fe9f6 /target
parentd798617d4aded6b922764bd5fea8651e12206afe (diff)
downloadopenwrt-047361dee44cab2b2355f7b7859fd688f6483cbc.tar.gz
openwrt-047361dee44cab2b2355f7b7859fd688f6483cbc.tar.bz2
openwrt-047361dee44cab2b2355f7b7859fd688f6483cbc.zip
treewide: cleanup kernel symbol references
We only use 5.15 kernel. So remove all those unnecessary symbols referencing 5.10 or 5.15 kernel. Can be found with: git grep -E 'LINUX_5_1(0|5)' Note that we remove the dependency from "sound-soc-chipdip-dac" instead of removing the complete kernel package. The 5.15 version bump forgot to delete the "@LINUX_5_10" dependency. The kernel package is still needed in 5.15 kernel. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/bcm27xx/modules/other.mk2
-rw-r--r--target/linux/bcm27xx/modules/sound.mk3
-rw-r--r--target/linux/pistachio/image/Makefile6
-rw-r--r--target/linux/x86/modules.mk2
4 files changed, 4 insertions, 9 deletions
diff --git a/target/linux/bcm27xx/modules/other.mk b/target/linux/bcm27xx/modules/other.mk
index a9103029ed..99b71d4d69 100644
--- a/target/linux/bcm27xx/modules/other.mk
+++ b/target/linux/bcm27xx/modules/other.mk
@@ -10,7 +10,7 @@ define KernelPackage/pwm-raspberrypi-poe
CONFIG_PWM_RASPBERRYPI_POE
FILES:=$(LINUX_DIR)/drivers/pwm/pwm-raspberrypi-poe.ko
AUTOLOAD:=$(call AutoLoad,20,pwm-raspberrypi-poe)
- DEPENDS:=@TARGET_bcm27xx @LINUX_5_15 +kmod-hwmon-pwmfan
+ DEPENDS:=@TARGET_bcm27xx +kmod-hwmon-pwmfan
endef
define KernelPackage/pwm-raspberrypi-poe/description
diff --git a/target/linux/bcm27xx/modules/sound.mk b/target/linux/bcm27xx/modules/sound.mk
index 182d80a2c8..47c0a93879 100644
--- a/target/linux/bcm27xx/modules/sound.mk
+++ b/target/linux/bcm27xx/modules/sound.mk
@@ -371,8 +371,7 @@ define KernelPackage/sound-soc-chipdip-dac
$(LINUX_DIR)/sound/soc/bcm/snd-soc-chipdip-dac.ko
AUTOLOAD:=$(call AutoLoad,68,snd-soc-chipdip-dac)
DEPENDS:= \
- kmod-sound-soc-bcm2835-i2s \
- @LINUX_5_10
+ kmod-sound-soc-bcm2835-i2s
$(call AddDepends/sound)
endef
diff --git a/target/linux/pistachio/image/Makefile b/target/linux/pistachio/image/Makefile
index 9c0e9da91f..64898b46e0 100644
--- a/target/linux/pistachio/image/Makefile
+++ b/target/linux/pistachio/image/Makefile
@@ -5,11 +5,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-ifdef CONFIG_LINUX_5_10
- KERNEL_LOADADDR := 0x80400000
-else
- KERNEL_LOADADDR := 0x80100000
-endif
+KERNEL_LOADADDR := 0x80100000
define Device/Default
PROFILES := Default
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index e0c3b4174f..f6a7c6c440 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -22,7 +22,7 @@ $(eval $(call KernelPackage,amazon-ena))
define KernelPackage/amd-xgbe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=AMD Ethernet on SoC support
- DEPENDS:=@PCI_SUPPORT @TARGET_x86_64 +kmod-lib-crc32c +kmod-ptp +kmod-libphy +(LINUX_5_10||LINUX_5_15):kmod-mdio-devres
+ DEPENDS:=@PCI_SUPPORT @TARGET_x86_64 +kmod-lib-crc32c +kmod-ptp +kmod-libphy +kmod-mdio-devres
KCONFIG:=CONFIG_AMD_XGBE
FILES:=$(LINUX_DIR)/drivers/net/ethernet/amd/xgbe/amd-xgbe.ko
AUTOLOAD:=$(call AutoLoad,35,amd-xgbe)